Opened 3 months ago

Closed 2 weeks ago

#3004 closed defect (done)

IslandGA parameterizes Evaluator's Random to GlobalRandom instead of LocalRandom

Reported by: abeham Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.16
Component: Algorithms.GeneticAlgorithm Version: trunk
Keywords: merged Cc:

Description

ALPS is also affected after changes following #2953.

The problem is that the Evaluator is part of the Operators collection which is wholly parameterized to GlobalRandom before individual operators are parameterized to LocalRandom. The evaluator is however not among those individual operators.

Soltuions are either to fire EvaluatorChanged after OperatorsChanged or to specifically wire the evaluator in IslandGA and ALPS to LocalRandom inside OperatorsChanged.

Change History (9)

comment:1 Changed 3 months ago by abeham

  • Owner set to abeham
  • Status changed from new to accepted

comment:2 Changed 3 months ago by abeham

  • Owner changed from abeham to pfleck
  • Status changed from accepted to reviewing

r16861: Fixed wiring of evaluator to LocalRandom instead of GlobalRandom (as intended in the code)

comment:3 Changed 3 months ago by pfleck

  • Version set to trunk

comment:4 Changed 4 weeks ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from reviewing to readytorelease

Reviewed r16861:

  • Tested ALPS, OS-ALPS and IslandGA and all evaluators are now correctly wired.

comment:5 Changed 3 weeks ago by abeham

  • Cc depends-2520 added

comment:6 Changed 3 weeks ago by abeham

  • Cc depends-2520 removed
  • Keywords depends-2520 added

comment:7 Changed 2 weeks ago by abeham

r17114: merged to stable (16861)

comment:8 Changed 2 weeks ago by abeham

  • Keywords merged added; depends-2520 removed

comment:9 Changed 2 weeks ago by abeham

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.