Free cookie consent management tool by TermsFeed Policy Generator

Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#86 closed task (rejected)

Rename formal variable name Point

Reported by: abeham Owned by: abeham
Priority: low Milestone: HeuristicLab 3.3.0
Component: ZZZ OBSOLETE: TestFunctions Version: 3.0
Keywords: Cc: gkronber


The (Rastrigin|Schwefel|Ackley|...) evaluators will most likely be coupled with operators from RealVector which inject and work on a variable called "RealVector" per default. The evaluators however expect a variable called "Point". It would be good to change the formal name to be RealVector as well.

Change History (7)

comment:1 Changed 16 years ago by swagner

  • Cc gkronber added

Hm, to be honest I'm not quite sure about that. In my opinion we should not start mixing terms from a problem domain with those from a solution representation domain. The TestFunctions plugin represents a problem that can be attacked using various solution representations. One of them is RealVector of course, but not the only one. I don't think it is a good idea to rename the input variable Point in TestFunctionEvaluatorBase to RealVector because this would suggest a strong coupling between the TestFunctions and the RealVector plugin which does not exist.

What do you think? Comments?

comment:2 Changed 16 years ago by abeham

You're absolutely right. Generally there can be multiple representations for a problem. Still the operators are written such that only RealVector (or another representation that builds on DoubleArrayData) is possible. That's why I suggested to name it RealVector flat.

comment:3 Changed 16 years ago by abeham

  • Owner changed from swagner to abeham
  • Status changed from new to assigned

comment:4 Changed 16 years ago by abeham

  • Resolution set to wontfix
  • Status changed from assigned to closed

After some discussion with Stefan, the distinction between the variable name and the underlying data representation is necessary to prevent the impression of a false correlation, similar to what Gabriel suggested.

comment:5 Changed 15 years ago by swagner

  • Milestone changed from 3.0 to Iteration 0

Milestone 3.0 deleted

comment:6 Changed 14 years ago by swagner

  • Milestone changed from Iteration 0 to Current

Milestone Iteration 0 deleted

comment:11 Changed 14 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.