Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#815 closed defect (done)

VariableImpactCalculators produce memory leaks

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.0
Component: ZZZ OBSOLETE: Modeling Version: 3.2
Keywords: Cc:

Description

The VariableImpactCalculators clone the given Dataset, which is afterwards modified to calculate the variable impact. The problem is that the TreeEvaluator within the IPredictor caches the dataset and so a copy of the Dataset is held in memory.

Change History (5)

comment:1 Changed 12 years ago by mkommend

  • Status changed from new to assigned

comment:2 Changed 12 years ago by mkommend

fixed memory leak in VariableImpactCalculators by cloning the IPredictor r2559

comment:3 Changed 11 years ago by mkommend

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 11 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 11 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.