Opened 6 weeks ago

Closed 42 hours ago

#3010 closed defect (done)

Checked item views are slow when a lot of items are checked at once

Reported by: abeham Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.16
Component: Core.Views Version: trunk
Keywords: Cc:

Description (last modified by abeham)

For instance, when selecting many input variables in the ProblemData the view takes several seconds until the selection is complete. Probably because each input variable is deselected in the process and for each deselected variable some computation occurs.

Change History (9)

comment:1 Changed 6 weeks ago by abeham

  • Owner set to abeham
  • Status changed from new to accepted

comment:2 Changed 6 weeks ago by abeham

  • Component changed from Problems.DataAnalysis.Views to Core.Views
  • Description modified (diff)
  • Summary changed from Selecting/Deselecting input variables is slow to Checked item views are slow when a lot of items are checked at once

comment:3 Changed 6 weeks ago by abeham

  • Owner changed from abeham to mkommend
  • Status changed from accepted to reviewing

r17009: Added batch methods for checking multiple items at once for CheckedItemList and CheckedItemCollection

These methods can be used to realize #1616

comment:4 Changed 3 weeks ago by abeham

  • Version set to trunk

comment:5 Changed 2 weeks ago by mkommend

  • Owner changed from mkommend to abeham
  • Status changed from reviewing to assigned

The code in r17009 looks fine. However, during testing I noticed that while fast clicking a check boxe with multiple items selected the view gets out of sync with the content behind, indicated by the number of checked items label.

comment:6 Changed 13 days ago by abeham

I think the problem is in the double-click handling. The doubleClick event is recognized in MouseDown. The ItemCheck event is called for each item anew, but for the first item doubleClick is reset to false, thus the remaining ItemCheck events are processed normally. Special handling of double clicks was added in r3788 as part of the initial release.

comment:7 Changed 13 days ago by abeham

  • Owner changed from abeham to mkommend
  • Status changed from assigned to reviewing

r17126: improved double click handling in checked collection views

comment:8 Changed 44 hours ago by mkommend

  • Owner changed from mkommend to abeham
  • Status changed from reviewing to readytorelease

Reviewed and tested r17126 that fixes the described issue.

comment:9 Changed 42 hours ago by abeham

  • Resolution set to done
  • Status changed from readytorelease to closed

r17147: merged to stable (17009, 17126)

Note: See TracTickets for help on using tickets.