Opened 6 months ago

Closed 3 months ago

#2957 closed enhancement (done)

Implement symbolic regression problem instances from "A multilevel block building algorithm for fast modeling generalized separable systems"

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.16
Component: Problems.Instances Version: trunk
Keywords: Cc:

Description (last modified by gkronber)

See: https://arxiv.org/abs/1706.02281

This paper uses data from physical formulas as benchmark problems. The formulas are complex (complex non-separable terms, several variables and variable references, etc.). It also describes comparisons with experiments using the "Eureka" software (convenient for further papers!).

Interesting formulas are listed in Equation 2.1, 2.2 and 2.4, ranges for variable values are in the appendix. Ranges for values and "readable" formulas are given in the appendix.

Change History (11)

comment:1 Changed 6 months ago by gkronber

  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 6 months ago by gkronber

  • Description modified (diff)

comment:3 Changed 6 months ago by gkronber

r16264: initial import of physics problems implemented by lkammere

comment:4 Changed 4 months ago by gkronber

r16394: reviewed implementation and made some adjustments.

The "maximum lift of whole aircraft" is only described in the arXiv version of the paper but has been removed in the peer-reviewed version for ESWA. There seems to be an error in the pre-print (x5 and x6 stand for only one variable in the original formula and the ranges for valid values are missing).

I decided to keep the problem and assumed a rather large range to make the problem more interesting for benchmarking purposes. All differences to the published version of the problem instances are described.

comment:5 Changed 4 months ago by gkronber

There were two significant changes made in r16394:

  • for the lift coefficicent, I changed x1*(x2 - 2) + ... to C_L = C_La (a + 2) + ... because the paper states that a0 is set to -2° in C_La (a - a0)
  • for the flow psi problem, I changed x1*x2*x5*(1 - x4²/x5²) + ... to V_inf r sin(th) (1 - R²/r²) + .... So it is now necessary to identify the function sin(th) as a factor.

comment:6 Changed 4 months ago by gkronber

  • Status changed from accepted to readytorelease
  • Version set to trunk

comment:7 Changed 4 months ago by lkammere

r16431: Fixed visibility of regression instance providers for physics benchmark problems.

comment:8 Changed 4 months ago by mkommend

  • Status changed from readytorelease to reviewing

comment:9 Changed 4 months ago by gkronber

  • Status changed from reviewing to readytorelease

Reviewed r16431.

comment:10 Changed 4 months ago by gkronber

r16495: merged r16264, r16394, r16431 from trunk to stable

comment:11 Changed 3 months ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.