Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#280 closed defect (worksforme)

Disposing mechanism of controls doesn't work reliably

Reported by: gkronber Owned by: gkronber
Priority: high Milestone: HeuristicLab 3.3.0
Component: General Version: 3.3
Keywords: Cc:

Description

In release builds the order in which Dispose() is called for garbage collected objects is random. This means that our current approach of disposing children of a control in it's Dispose() method doesn't work reliably. Meaning it tries to dispose objects which have already been disposed or garbage collected.

This defect often leads to crashes when closing the application

Change History (6)

comment:1 Changed 14 years ago by gkronber

  • Owner changed from swagner to gkronber

comment:2 Changed 14 years ago by swagner

  • Milestone changed from 3.2 to Iteration 0

Milestone 3.2 deleted

comment:3 Changed 13 years ago by gkronber

Related to #183.

comment:4 Changed 12 years ago by gkronber

  • Resolution set to worksforme
  • Status changed from new to closed
  • Version changed from 3.2 to 3.3

Couldn't reproduce this problem with HeuristicLab 3.3 for some time now.

comment:5 Changed 12 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 12 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.