Opened 2 years ago

Closed 10 months ago

Last modified 10 months ago

#2581 closed feature request (obsolete)

Monte Carlo Tree Search (MCTS) for symbolic regression models

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.15
Component: Algorithms.DataAnalysis Version: 3.3.13
Keywords: Cc:

Description


Change History (29)

comment:1 Changed 2 years ago by gkronber

  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 2 years ago by gkronber

r13645: added MCTS for symbolic regression models

comment:3 Changed 2 years ago by gkronber

r13648: added unit test for MCTS for symbolic regression

comment:4 Changed 2 years ago by gkronber

r13650: fixed license header

comment:5 Changed 2 years ago by gkronber

r13651:

  • added unit tests for the number of different expressions
  • fixed problems in Automaton and constraintHandler that lead to duplicate expressions
  • added possibility for MCTS to handle dead-ends in the search tree (when it is not possible to construct a valid new expression)
  • added statistics on function and gradient evaluations

comment:6 Changed 2 years ago by gkronber

r13652:

  • removed simplification of trees (temporarily for better debugging)
  • renamed MaxSize parameter
  • fixed a small bug in MCTS
  • changed SymbolicExpressionGenerator to produce trees in the correct order

comment:7 Changed 2 years ago by gkronber

r13654: adaptad parameter name in unit test

comment:8 Changed 2 years ago by gkronber

r13657: update quality estimate in parent nodes when a branch is completely explored. added ucbtuned selection

comment:9 Changed 2 years ago by gkronber

r13658: extracted policies from MCTS to allow experimentation with different policies for MCTS

comment:10 Changed 2 years ago by gkronber

r13659: added source files for policies

comment:11 Changed 2 years ago by gkronber

r13661: updated unit test to compile with r13658

comment:12 Changed 2 years ago by gkronber

r13662: made cloning constructor protected

comment:13 Changed 2 years ago by gkronber

r13669: made policies storable and added iteration of best solution to results

comment:14 Changed 2 years ago by mkommend

The unit tests for MCTS do not fix the random seed and hence fail randomly (especially for Nguyen-3).

comment:15 Changed 2 years ago by gkronber

r13708: removed TestMethod attribute from unit tests using randomly sampled data because of a problem in the regression problem instances (see #2371)

comment:16 Changed 22 months ago by gkronber

  • Milestone changed from HeuristicLab 3.3.14 to HeuristicLab 3.3.15

comment:17 Changed 21 months ago by jkarder

r14142: fixed compiler warnings

comment:18 Changed 19 months ago by gkronber

  • Code for the automaton to generate expressions should be refactored
  • Add support for heuristics for choosing branches to explore (based also on partial evaluation of expressions)

comment:19 Changed 12 months ago by gkronber

  • Milestone changed from HeuristicLab 3.3.15 to HeuristicLab 3.3.x Backlog

comment:20 Changed 10 months ago by gkronber

r15056: Created a branch for MCTS-SymbReg

comment:21 Changed 10 months ago by gkronber

r15057: copied MctsSymbolicRegression and unit tests from trunk to branch

comment:22 Changed 10 months ago by gkronber

r15058: deleted MctsSymbolicRegression and unit tests from trunk so that the changesets in this ticket can be released and this ticket can be closed.

comment:23 Changed 10 months ago by gkronber

A follow up ticket has been created to track the branch developments (#2796).

comment:24 Changed 10 months ago by gkronber

r15060: merged r13645, r13648, r13650, r13651, r13652, r13654, r13657, r13658, r13659, r13661, r13662, r13669, r13708, r14142 from trunk to stable (to be deleted in the next commit)

Last edited 10 months ago by gkronber (previous) (diff)

comment:25 Changed 10 months ago by gkronber

Merge #2524 from trunk to stable before r15058

comment:26 Changed 10 months ago by gkronber

r15062: merged r14135 (made within #2639) from trunk to stable

comment:27 Changed 10 months ago by gkronber

r15063: merged r15058 from trunk to stable (forcing deletion of MctsSymbolicRegression folder which gave a tree conflict)

comment:28 Changed 10 months ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.15
  • Resolution set to obsolete
  • Status changed from accepted to closed

comment:29 Changed 10 months ago by gkronber

Closed this ticket because the development has been moved to a branch (#2796) and all changesets in this ticket have been merged to stable.

Note: See TracTickets for help on using tickets.