Opened 4 years ago

Closed 2 years ago

#2371 closed defect (done)

Setting the seed for ValueGenerator not possible (for data analysis problems)

Reported by: gkronber Owned by: gkronber
Priority: high Milestone: HeuristicLab 3.3.15
Component: Problems.Instances Version: 3.3.11
Keywords: Cc:

Description (last modified by gkronber)

This is for instance relevant for the (random) generation of benchmark instance datasets because it is not possible to fully reproduce a dataset.

Change History (14)

comment:1 Changed 4 years ago by gkronber

  • Description modified (diff)
  • Owner set to gkronber
  • Status changed from new to accepted

comment:2 Changed 3 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.12 to HeuristicLab 3.3.x Backlog
  • Status changed from accepted to assigned

comment:3 Changed 3 years ago by gkronber

  • Priority changed from medium to high
  • Status changed from assigned to accepted

comment:4 Changed 2 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.15

comment:5 Changed 2 years ago by gkronber

r14228: added constructors to allow specification of random seeds for randomly generated regression problem instances (primarily for unit tests)

comment:6 Changed 2 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:7 Changed 2 years ago by gkronber

r14229: removed usage of C# 6.0 readonly properties

comment:8 Changed 2 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to assigned

Reviewed r14228 and r14229. Changes look good wrt the actual source.

However, the possibility to set the seed for one instance provider is never used or have I overlooked the according call?

I still can't reproduce the datasets, because I don't know the seed which has been used to create the problem data => I don't see an improvement in r14228 or r14229 as long as the seeding methods are not used anywhere in HL or the seed is accessible from the problemData or dataset.

comment:9 Changed 2 years ago by gkronber

The seeding is (should be) used primarily for unit tests.

Of course we can discuss how we can or should allow viewing and changing the seed in the GUI.

comment:10 Changed 2 years ago by mkommend

  • Owner changed from gkronber to mkommend
  • Status changed from assigned to reviewing

Ok.

comment:11 Changed 2 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

comment:12 Changed 2 years ago by gkronber

Created a ticket for the required GUI changes (#2671)

comment:13 Changed 2 years ago by gkronber

r14305: merged r14228, r14229 from trunk to stable

comment:14 Changed 2 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.