Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1832 closed feature request (duplicate)

Support tree edit operations in the simplifier view

Reported by: bburlacu Owned by: bburlacu
Priority: medium Milestone:
Component: Problems.DataAnalysis.Symbolic Version: branch
Keywords: Cc:

Description (last modified by bburlacu)

The tree model in the simplifier view should support the following operations:

  • inserting an intermediate symbol between two nodes (ideally by selection or drag&drop from the available grammar)
  • removing nodes/sub-trees (removing intermediate symbols or whole branches)
  • "moving" nodes/sub-trees (manual simplification/collapsing or just some kind of copy/paste operation)

This ticket is a duplicate of #1763

Change History (5)

comment:1 Changed 8 years ago by bburlacu

  • Version changed from 3.3.6 to branch

comment:2 Changed 8 years ago by bburlacu

  • Cc mkommend removed
  • Owner changed from mkommend to bburlacu
  • Status changed from new to assigned

comment:3 Changed 8 years ago by bburlacu

r7784: Moved replacement and impact values calculation code from view to separate files. Implemented simplifier actions: copy, cut, delete, insert node/subtree.

comment:4 Changed 8 years ago by bburlacu

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:5 Changed 8 years ago by mkommend

  • Milestone HeuristicLab 3.3.x Backlog deleted
Note: See TracTickets for help on using tickets.