Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1028 closed defect (done)

Symbolic expression grammars are not cloned correctly

Reported by: gkronber Owned by: mkommend
Priority: high Milestone: HeuristicLab 3.3.1
Component: Encodings.SymbolicExpressionTreeEncoding Version: 3.3.1
Keywords: Cc:

Description


Change History (19)

comment:1 Changed 11 years ago by gkronber

  • Status changed from new to assigned

comment:2 Changed 11 years ago by gkronber

Fixed bug in cloning of symbolic expression grammars with r3885.

comment:3 Changed 11 years ago by gkronber

  • Version changed from 3.3 to 3.3.1

When a problem is cloned the symbols in the symbolic expression grammar are not cloned correctly.

comment:4 Changed 11 years ago by gkronber

  • Priority changed from minor to critical

Related to #1140

comment:5 Changed 11 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from assigned to new

comment:6 Changed 11 years ago by mkommend

  • Status changed from new to assigned

comment:7 Changed 11 years ago by mkommend

Refactored grammars in r4249.

comment:8 Changed 11 years ago by mkommend

Adapted SymbolicRegression classes to new grammars in r4250.

comment:9 Changed 11 years ago by mkommend

  • Status changed from assigned to accepted

comment:10 Changed 11 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

comment:11 Changed 11 years ago by mkommend

Updated grammars in DataAnalysis branch r4252.

comment:12 Changed 11 years ago by mkommend

Made DefaultGrammar abstract and sealed GlobalGrammar r4262.

comment:13 follow-up: Changed 11 years ago by gkronber

  • Owner changed from gkronber to mkommend

reviewed: r4262, r4250 and r4249.

Please check if ResultsView for symbolic regression solutions works correctly when the estimated values list contains NaN elements. If the results view shows correct values feel free to close the ticket.

comment:14 Changed 11 years ago by mkommend

Reverted incorrect commit (r4250) regarding the registration of parameter events and chained deserialization ctor correctly with r4291.

comment:15 Changed 11 years ago by mkommend

Added null check before event registration with r4295.

comment:16 in reply to: ↑ 13 Changed 11 years ago by mkommend

Replying to gkronber:

reviewed: r4262, r4250 and r4249.

Please check if ResultsView for symbolic regression solutions works correctly when the estimated values list contains NaN elements. If the results view shows correct values feel free to close the ticket.

The ResultsView can not handle NaN elements because the calculators used could not handle them. Although this is only a problem if the training or the test partition contain NaN elements and this is not possible during an algorithm run.

comment:17 Changed 11 years ago by mkommend

  • Resolution set to done
  • Status changed from reviewing to closed

comment:18 Changed 10 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 10 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.