Opened 20 months ago

Closed 12 months ago

Last modified 12 months ago

#2526 closed task (done)

Release HeuristicLab 3.3.14

Reported by: ascheibe Owned by: swagner
Priority: medium Milestone: HeuristicLab 3.3.14
Component: General Version: 3.3.13
Keywords: Cc:

Description (last modified by swagner)

Codename:

  • Denver

New Features:

  • BinPacking
  • Probabilistic TSP
  • Multi-objective Testfunctions
  • Elastic-net, nonlinear regression, gradient boosted regression
  • Gradient charts
  • Bugfixes

Release Steps:

Stable Branch:

  1. Increment plugin and application versions
  2. Update versions in plugin dependencies
  3. Increment assembly file versions
  4. Increment installer versions
  5. Check and if necessary update year of copyrights
  6. Check and if necessary update build configurations and project dependencies
  7. Check if all unit tests are passed
  8. Update samples
  9. Create release tag
  10. Merge commits back into trunk

Release tag:

  1. Build configuration Release Any CPU
  2. Check if it compiles with mono
  3. Remove unnecessary files from build output (*.vshost.exe, *.vshost.exe.config, *.vshost.exe.manifest, *.pdb, *.dll.config (do not remove DotNetScilab-1.0.dll.config, that's a plugin dependency), app.config)
  4. Hide HeuristicLab 3.3.exe.config
  5. Create zip file

Trac:

  1. Attach zip file to Download wiki page
  2. Update wiki pages Download, ChangeLog, ChangeLogPending, etc. (download button for current version is always called HL-Download.png)
  3. Create new milestone for the next release
  4. Change description of the current milestone into changelog style
  5. Update ChangeLogPending to display tickets of the next release milestone
  6. Complete current milestone and retarget all its remaining open tickets
  7. Update default version in the trac Admin module

Documentation:

  1. Update tutorial slides (latest version, number of plugins, algorithms and problems, features)

Marketing and PR:

  1. Post info about new release on HEAL homepage, HeuristicLab Facebook fan page and LinkedIn
  2. Write a release announcement for the Blog and send a mail to our mailing list
  3. Update Wikipedia page
  4. Push to github
  5. Update Features page
  6. Inform everybody else who might be interested

Change History (44)

comment:1 Changed 19 months ago by ascheibe

  • Status changed from new to accepted

comment:2 Changed 19 months ago by ascheibe

r13499: removed SharpDX from Mono builds as it does not work on Linux

comment:3 Changed 19 months ago by gkronber

Thanks!

comment:4 Changed 18 months ago by ascheibe

r13509 fixed post build events in Hive slave project

comment:5 Changed 17 months ago by gkronber

r13644: fixed a typo in the name & description of a benchmark problem

comment:6 Changed 13 months ago by ascheibe

  • Owner changed from ascheibe to swagner
  • Status changed from accepted to assigned

comment:7 Changed 12 months ago by mkommend

  • Description modified (diff)

comment:8 Changed 12 months ago by swagner

  • Status changed from assigned to accepted

comment:9 Changed 12 months ago by swagner

  • Description modified (diff)

comment:10 Changed 12 months ago by swagner

  • Description modified (diff)

comment:11 Changed 12 months ago by jkarder

r14143: updated hl download images

comment:12 Changed 12 months ago by swagner

r14171: Updated year of copyrights

comment:13 Changed 12 months ago by swagner

  • Description modified (diff)

r14183: Updated year of copyrights on stable

comment:14 Changed 12 months ago by swagner

r14185: Updated year of copyrights in license headers

comment:15 Changed 12 months ago by swagner

r14186: Updated year of copyrights in license headers on stable

comment:16 Changed 12 months ago by swagner

r14187: Updated year of copyrights in license headers

comment:17 Changed 12 months ago by swagner

r14188: Updated year of copyrights in license headers on stable

comment:18 Changed 12 months ago by swagner

r14190: Updated versions

comment:19 Changed 12 months ago by jkarder

r14191: fixed build configurations

comment:20 Changed 12 months ago by jkarder

r14192: merged r14191 into stable

comment:21 Changed 12 months ago by jkarder

r14193: merged r13499, r13509 and r13644 into stable

comment:22 Changed 12 months ago by swagner

  • Description modified (diff)

comment:23 Changed 12 months ago by swagner

r14195: Merged r14190 from stable back into trunk

comment:24 Changed 12 months ago by swagner

r14203: Updated samples

comment:25 Changed 12 months ago by swagner

r14204: Updated samples

comment:26 Changed 12 months ago by abeham

r14206: updated robocode sample and unit test to create a valid sample even if jdk was not installed

comment:27 Changed 12 months ago by swagner

r14207: Corrected post build events and config merging

comment:28 Changed 12 months ago by swagner

r14208: Updated svn ignores

comment:29 Changed 12 months ago by abeham

r14209: manually excluded SimpleSymbol from the types checked for deep clonability (it's a non-discoverable type)

comment:30 Changed 12 months ago by swagner

r14211: Merged r14203, r14204, r14206, r14207, r14209 into stable

comment:31 Changed 12 months ago by swagner

r14212: Fixed projects in solution file on stable because merge of r14201 missed to remove GE 3.3 correctly

comment:32 Changed 12 months ago by swagner

r14213: Updated svn ignores on stable

comment:33 Changed 12 months ago by swagner

  • Description modified (diff)

comment:34 Changed 12 months ago by swagner

r14214: Created HL 3.3.14 release tag

comment:35 Changed 12 months ago by swagner

  • Description modified (diff)

comment:36 Changed 12 months ago by swagner

  • Description modified (diff)

comment:37 Changed 12 months ago by swagner

  • Status changed from accepted to readytorelease

comment:38 Changed 12 months ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed

comment:39 Changed 12 months ago by swagner

  • Description modified (diff)

comment:40 Changed 12 months ago by swagner

  • Description modified (diff)

r14215: Updated tutorial slides

comment:41 Changed 12 months ago by swagner

  • Description modified (diff)

comment:42 Changed 12 months ago by swagner

  • Description modified (diff)

comment:43 Changed 12 months ago by swagner

  • Description modified (diff)

comment:44 Changed 12 months ago by swagner

  • Description modified (diff)
Note: See TracTickets for help on using tickets.