Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#990 closed enhancement (done)

Refactor mechanism for saving and loading items

Reported by: swagner Owned by: swagner
Priority: low Milestone: HeuristicLab 3.3.0
Component: Common Version: 3.3
Keywords: Cc:

Description

Due to the changes of #980 the mechanism for saving and loading items should be refactored to use the new ContentManager.

Change History (10)

comment:1 Changed 11 years ago by swagner

  • Status changed from new to assigned

comment:2 Changed 11 years ago by swagner

Worked on in r3483.

comment:3 Changed 11 years ago by swagner

Removed "Save All" in r3498.

comment:4 Changed 11 years ago by swagner

Finished in r3500.

comment:5 Changed 11 years ago by swagner

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 11 years ago by gkronber

  • Resolution fixed deleted
  • Status changed from closed to reopened

Cross-thread exceptions are caused by the changes in r3500 (making loading async).

comment:7 Changed 11 years ago by gkronber

Fixed cross-thread exception potential in AlgorithmView with r3548.

comment:8 Changed 11 years ago by gkronber

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed 11 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 11 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.