Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#893 closed task (done)

HeuristicLab 3.3.0 application review

Reported by: swagner Owned by: swagner
Priority: highest Milestone: HeuristicLab 3.3.0
Component: General Version: 3.3
Keywords: Cc: abeham

Description

This ticket tracks efforts of the application review of all components related to HeuristicLab 3.3.0.

All review comments should be published on the wiki pages of the HeuristicLab 3.3.0 Application Review.

Change History (93)

comment:1 Changed 11 years ago by swagner

  • Status changed from new to assigned

comment:2 Changed 11 years ago by swagner

Implemented reviewers' comments in r2953.

comment:3 Changed 11 years ago by swagner

Implemented reviewers' comments in r2989.

comment:4 Changed 11 years ago by abeham

  • Cc abeham added

comment:5 Changed 11 years ago by swagner

Renamed SGAOperator to SGAMainLoop in r3020.

comment:6 Changed 11 years ago by swagner

Restricted name changes of operators to CombinedOperator, Placeholder and ProgrammableOperator in r3024.

comment:7 Changed 11 years ago by swagner

Fixed capitalization of algorithm names in r3026.

comment:8 Changed 11 years ago by swagner

After a discussion with abeham, set name changing capabilities of operators in r3034.

comment:9 Changed 11 years ago by swagner

Implemented tracking of best and best known quality values (see #920).

comment:10 Changed 11 years ago by swagner

Implemented reviewers' comments in r3210, r3213 and r3214.

comment:11 Changed 11 years ago by swagner

Refactored results handling in r3226.

comment:12 Changed 11 years ago by swagner

Implemented reviewers' comments in r3289.

comment:13 Changed 11 years ago by swagner

Implemented reviewers' comments in r3290.

comment:14 Changed 11 years ago by swagner

Implemented reviewers' comments in r3304.

comment:15 Changed 11 years ago by swagner

Implemented reviewers' comments in r3306.

comment:16 Changed 11 years ago by swagner

Fixed bug which was introduced in r3306 in r3327.

comment:17 Changed 11 years ago by swagner

Implemented reviewers' comments in r3341.

comment:18 Changed 11 years ago by swagner

Implemented reviewers' comments in r3351.

comment:19 Changed 11 years ago by swagner

Implemented reviewers' comments in r3372.

comment:20 Changed 11 years ago by swagner

Implemented reviewers' comments in r3396.

comment:21 Changed 11 years ago by swagner

Implemented reviewers' comments in r3402.

comment:22 Changed 11 years ago by swagner

Implemented reviewers' comments in r3501.

comment:23 Changed 11 years ago by swagner

Implemented reviewers' comments in r3502, r3503 and r3504.

comment:24 Changed 11 years ago by swagner

Implemented reviewers' comments in r3505.

comment:25 Changed 11 years ago by swagner

Implemented reviewers' comments in r3517.

comment:26 Changed 11 years ago by swagner

Implemented reviewers' comments in r3518 and r3519.

comment:27 Changed 11 years ago by swagner

Implemented reviewers' comments in r3525.

comment:28 Changed 11 years ago by swagner

Implemented reviewers' comments in r3526.

comment:29 Changed 11 years ago by abeham

Implemented reviewers' comments in r3527

  • MultiCrossovers throw an exception when no crossover has been added

comment:30 Changed 11 years ago by swagner

Implemented reviewers' comments in r3528.

comment:31 Changed 11 years ago by swagner

Fixed exceptions in r3550.

comment:32 Changed 11 years ago by swagner

Implemented reviewers' comments in r3551.

comment:33 Changed 11 years ago by swagner

Fixed exceptions in r3552.

comment:34 Changed 11 years ago by swagner

Fixed exceptions in r3561.

comment:35 Changed 11 years ago by swagner

Fixed bug in GA wiring in r3680.

comment:36 Changed 11 years ago by swagner

Implemented reviewers`comments in r3688.

comment:37 Changed 11 years ago by abeham

r3689

  • fixed wiring in the algorithms

comment:38 Changed 11 years ago by swagner

Implemented reviewers' comments in r3694.

comment:39 Changed 11 years ago by abeham

r3698

  • fixed review comments regarding comparison factor results / modification
  • corrected the description of a parameter
  • removed unnecessary parameters

comment:40 Changed 11 years ago by abeham

r3699

  • fixed replacement in OSGA, Island OSGA, and SASEGASA

comment:41 Changed 11 years ago by gkronber

Adjust zoom interval in DataTableView based on range of displayed values. Added functionality to hide and show series with r3703.

comment:42 Changed 11 years ago by gkronber

Added adjustment of cursor interval based on range of displayed values in the RunCollectionBubbleChartView ScatterPlotView and LineChartView with r3707.

comment:43 Changed 11 years ago by gkronber

Implemented reviewer comments with r3710.

comment:44 Changed 11 years ago by abeham

r3713

  • changed elites replacement in all offspring selection algorithms

comment:45 Changed 11 years ago by abeham

r3715

  • prevented exception in the algorithms when an operator parameter from the problem is missing

comment:46 Changed 11 years ago by abeham

r3725

  • fixed uneditable state of user defined algorithm after execution

comment:47 Changed 11 years ago by abeham

r3735

  • changed description of the SelectedParents parameter in the OS Algorithms

comment:48 Changed 11 years ago by gkronber

Added about dialog in plugin infrastructure and optimizer with r3736.

comment:49 Changed 11 years ago by abeham

r3740

  • Changed the way offspring selection works
  • Added depth parameter to ScopeTreeLookupParameter

comment:50 Changed 11 years ago by swagner

Added "Do you want to close Optimizer" dialog in r3741.

comment:51 Changed 11 years ago by gkronber

Fixed GPL license headers and deleted files which are not referenced by projects with r3742 and r3743.

find -name *.cs -exec grep -L  '* Copyright (C) 2002-2010 Heuristic and Evolutionary Algorithms Laboratory (HEAL)' {}  \;
Last edited 11 years ago by gkronber (previous) (diff)

comment:52 Changed 11 years ago by abeham

r3744

  • Changed initialization of comparison factor
  • fixed some bugs in OffspringSelector

comment:53 Changed 11 years ago by abeham

r3750

  • Fixed wiring of iteration based operators like the michalewicz manipulators for real vector encoding

comment:54 Changed 11 years ago by abeham

r3751

  • fixed parameterization of strategy parameter operators in the test functions

comment:55 Changed 11 years ago by gkronber

Implemented reviewers' comments (default format for bitmaps is png not bmp) with r3753.

comment:56 Changed 11 years ago by swagner

Implemented reviewers` comments in r3759.

  • added menu item for creating user-defined algorithms and removed button

comment:57 Changed 11 years ago by mkommend

adapted view captions r3764

comment:58 Changed 11 years ago by swagner

Enabled name/description editing in runs in r3766.

comment:59 Changed 11 years ago by swagner

Enhanced Optimizer settings to customize appearance in r3768.

comment:60 Changed 11 years ago by swagner

Fixed bug in EngineAlgorithm and UserDefinedAlgorithmView in r3770.

comment:61 Changed 11 years ago by gkronber

Added display of data-point index to tooltip in DataTableView with r3773.

comment:62 Changed 11 years ago by gkronber

Renamed Variable Frequencies result with r3774.

comment:63 Changed 11 years ago by swagner

Added automatic re-selection of elements in collection views when the content of the view is changed in r3775.

comment:64 Changed 11 years ago by mkommend

Implemented reviewers' comment ( A possibility to view the values in tabular form would be nice)in r3767.

comment:65 Changed 11 years ago by mkommend

implemented check for MS ChartControls r3776

comment:66 Changed 11 years ago by mkommend

corrected AssemblyString for MS ChartControls r3778

comment:67 Changed 11 years ago by mkommend

corrected AssemblyString for MS ChartControls r3780

comment:68 Changed 11 years ago by mkommend

corrected ChartControlsWarning r3784

comment:69 Changed 11 years ago by abeham

r3787

  • Removed best known quality tracking from BestAverageWorstQualityAnalyzer
  • Added best known quality / solution tracking to problem specific analyzers

comment:70 Changed 11 years ago by mkommend

corrected behavior of CheckedItemCollectionViews r3788

comment:71 Changed 11 years ago by abeham

r3789

  • Updated wiring of problem specific analyzers

comment:72 Changed 11 years ago by abeham

r3790

  • Updated ValidationBestScaledSymbolicRegressionSolutionAnalyzer to track BestKnownQuality

comment:73 Changed 11 years ago by abeham

r3791

  • fixed wiring of the previous commit

comment:74 Changed 11 years ago by mkommend

fixed Optimizer GUI r3794

comment:75 Changed 11 years ago by mkommend

corrected opening of views from the RunCollectionView r3796.

comment:76 Changed 11 years ago by mkommend

corrected namespaces and removed resources files in HL 3.3 solution r3797

comment:77 Changed 11 years ago by mkommend

fixed enabled state of play button in AntTrailView r3795

comment:78 Changed 11 years ago by gkronber

Implemented fix for exceptions in CheckedItemCollection and CheckedItemCollection with r3798.

comment:79 Changed 11 years ago by gkronber

Changed execution order of analyzers (algorithm analyzers after problem analyzers) with r3799. @abeham: please review.

Note: I didn't change algorithms: Tabu Search and Local Search.

Last edited 11 years ago by gkronber (previous) (diff)

comment:80 Changed 11 years ago by gkronber

Fixed best known solution tracking for symbolic regression problems with r3800.

comment:81 Changed 11 years ago by gkronber

Updated GP examples after changes in analyzers with r3804.

comment:82 Changed 11 years ago by abeham

r3809

  • fixed BestKnownQuality tracking in tabu search and local search

comment:83 Changed 11 years ago by abeham

r3810

  • updated samples

comment:84 Changed 11 years ago by swagner

Removed folder which contained the MS Chart Controls binaries, help files and samples in r3815.

comment:85 Changed 11 years ago by swagner

Removed sorting of analyzer provided by problems in r3816.

comment:86 Changed 11 years ago by swagner

Implemented reviewers' comments in r3817.

comment:87 Changed 11 years ago by swagner

Enabled DataTableValuesCollector to collect int values in r3818.

comment:88 Changed 11 years ago by swagner

Implemented reviewers' comments in r3819.

comment:89 Changed 11 years ago by mkommend

fixed performance critical bug in DataTable r3826

comment:90 Changed 11 years ago by swagner

Implemented reviewers' comments in r3829.

comment:91 Changed 11 years ago by swagner

  • Resolution set to fixed
  • Status changed from assigned to closed

The reviewing phase of HeuristicLab 3.3.0 has ended with the release of version 3.3.0. Remaining issues should be treated in more specific tickets.

comment:92 Changed 11 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 10 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.