Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#823 closed enhancement (done)

Implement tree evaluator with linear scaling to improve convergence in symbolic regression.

Reported by: gkronber Owned by: gkronber
Priority: lowest Milestone: HeuristicLab 3.3.0
Component: ZZZ OBSOLETE: GP.StructureIdentification Version: 3.2
Keywords: Cc:

Description

As described in "Improving Symbolic Regression with Interval Arithmetic and Linear Scaling", Keijzer, Proceedings of EuroGP'2003, LNCS 2610, pp 70-82, Springer Verlag, 2003.

Change History (12)

comment:1 Changed 10 years ago by gkronber

  • Status changed from new to assigned

comment:2 Changed 10 years ago by gkronber

Added operators with r2579.

comment:3 Changed 10 years ago by gkronber

The linear scaling operator generates different estimations for the same sample when a different range of rows is evaluated. This causes major headaches concerning model-analysis and validation.

Linear scaling should only be used in the learning process on the training and validation sets. The final model should contain the scaling factor and offset in the model structure so that it can be evaluated with a default tree evaluator (HL3TreeEvaluator).

comment:4 Changed 10 years ago by gkronber

Added target variable property for the scaling tree evaluator with r2634.

comment:5 Changed 10 years ago by gkronber

Removed the restriction of the estimated value to the range [LowerBound..UpperBound] because the estimation is scaled anyway. However the scaled values are restricted to that range with r2640.

comment:6 Changed 10 years ago by gkronber

A linear scaling predictor builder is also needed to generate a correctly scaled final solution.

comment:7 Changed 10 years ago by gkronber

Added a special predictor builder for linear scaling tree evaluation and changed default GP engines to use linear scaling evaluators with r2722.

comment:8 Changed 9 years ago by gkronber

Moved linear scaling functionality out of tree evaluator into a separate operator with r2977.

comment:9 Changed 9 years ago by gkronber

Fixed bug in regression engines with r2979.

comment:10 Changed 9 years ago by gkronber

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:11 Changed 9 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 9 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.