Opened 13 years ago

Closed 13 years ago

Last modified 10 years ago

#35 closed defect (rejected)

When closing an control in the AdvancedOptimizationFrontend the first control of the group is displayed instead of the previously displayed control

Reported by: gkronber Owned by: swagner
Priority: low Milestone: HeuristicLab 3.3.0
Component: ZZZ OBSOLETE: AdvancedOptimizationFrontend Version: 3.0
Keywords: Cc:

Description

This is strange behavior because if there are two open controls (in tabs) and a new control is opened in the same group then after the newly created control is closed again the expected behavior is that the previously displayed control is displayed again. Instead the frontend displays the first control of the set.

Change History (9)

comment:1 Changed 13 years ago by gkronber

  • Summary changed from When closing an control in the AdvancedOptimizationFrontend the first control of the group is displayed instead to When closing an control in the AdvancedOptimizationFrontend the first control of the group is displayed instead of the previously displayed control

comment:2 Changed 13 years ago by swagner

Sorry, but I'm not able to reproduce this situation. I did the following:

  1. Open an SGA engine
  2. Double click on SGA Main to open a new view
  3. Double click on Replacement to open another new view
  4. Close the Replacement view again

Then, as expected, the SGA Main view is active again and not the initial SGA view.

Did I miss anything?

comment:3 follow-up: Changed 13 years ago by gkronber

Sorry, my description of the problem was inaccurate because the situation only happens in a special case.

  1. Open SGA engine
  2. Open SGA Main
  3. Drag the SGA Main control to the right side (to view SGA and SGA Main side by side)
  4. Drag SGA Main onto the center of the left side. (To restore the previous tabbed view)
  5. Open Replacement in SGA Main
  6. Close Replacement
  7. SGA is on top instead of SGA Main

After further consideration this seems to be a bug in the DockManager control of Weifen Luo. We should probably close this ticket as "won't fix" because the bug happens only in special circumstances and it would require fixing external code.

comment:4 in reply to: ↑ 3 Changed 13 years ago by gkronber

Replying to gkronber:

  1. Open SGA engine
  2. Open SGA Main
  3. Drag the SGA Main control to the right side (to view SGA and SGA Main side by side)
  4. Drag SGA Main onto the center of the left side. (To restore the previous tabbed view)
  5. Open Replacement in SGA Main
  6. Close Replacement
  7. SGA is on top instead of SGA Main

comment:5 Changed 13 years ago by swagner

Ah, now I got it.

Yes, this seems to be a bug in Weifen Luo's DockPanel Suite. I also think we should not bother too much about that for now and close the ticket as "won't fix".

comment:6 Changed 13 years ago by swagner

  • Resolution set to wontfix
  • Status changed from new to closed

comment:7 Changed 12 years ago by swagner

  • Milestone changed from 3.0 to Iteration 0

Milestone 3.0 deleted

comment:8 Changed 10 years ago by swagner

  • Milestone changed from Iteration 0 to Current

Milestone Iteration 0 deleted

comment:11 Changed 10 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.