Opened 9 months ago

Closed 8 months ago

#3111 closed defect (done)

RandomForestClassification produces a result (RF Model Evaluation) incorrectly

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.17
Component: Algorithms.DataAnalysis Version: trunk
Keywords: Cc:

Description

The list is populated with models but the models cannot be shown.

Might be related to a recent change for classification problems (#3102).

Steps to reproduce:

  1. New Random Forest Classification
  2. Run
  3. Check Results -> Random forest classification solution -> RF Model Evaluation

Change History (7)

comment:1 Changed 9 months ago by mkommend

  • Owner changed from bburlacu to mkommend
  • Status changed from new to accepted

comment:2 Changed 9 months ago by mkommend

The issue here is just a cast issue due to the refactoring to use surrogate or full models for RF.

comment:3 Changed 9 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

r17859: Fixed display of models in RFModelEvaluationView.

comment:4 Changed 9 months ago by mkommend

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.17
  • Version set to trunk

comment:5 Changed 9 months ago by gkronber

  • Status changed from reviewing to readytorelease

Reviewed r17859. Thanks!

comment:6 Changed 8 months ago by gkronber

r17926: merged r17859 from trunk to stable

comment:7 Changed 8 months ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.