Opened 15 months ago

Closed 9 months ago

#3083 closed defect (done)

LaTeX output for symbolic regression models is incorrect for target variables which contain special symbols

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.17
Component: Problems.DataAnalysis.Symbolic Version: trunk
Keywords: Cc:

Description

For instance if the target variable contains '_' then LaTeX interprets this as subscript symbol. As a consequence the mathematical representation of symbolic regression models is not shown correctly.

Change History (10)

comment:1 Changed 15 months ago by gkronber

  • Status changed from new to accepted

comment:2 Changed 15 months ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

r17755: use \text{} command for setting the target variable name.

comment:3 Changed 11 months ago by mkommend

  • Version set to trunk

comment:4 Changed 11 months ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

Reviewed r17755.

comment:5 Changed 10 months ago by gkronber

  • Status changed from readytorelease to assigned

comment:6 Changed 10 months ago by gkronber

r17755 introduced a bug because targetVariable can be null.

comment:7 Changed 10 months ago by gkronber

r17826: fixed problem when targetVariable = null

comment:8 Changed 9 months ago by gkronber

  • Status changed from assigned to readytorelease

comment:9 Changed 9 months ago by gkronber

r17870: merged r17755 and r17826 from trunk to stable

comment:10 Changed 9 months ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.