Opened 16 months ago

Closed 3 months ago

#3076 closed enhancement (obsolete)

Interval Arithmetic Evaluators and Analyzers

Reported by: chaider Owned by: chaider
Priority: medium Milestone: HeuristicLab 3.3.17
Component: Problems.DataAnalysis.Symbolic.Regression Version: trunk
Keywords: Cc:

Description

Extend the Interval Arithmetic with different evaluators and analyzers.

  • SingleObjective Evalautors
  • MultiOjbective Evalautors

Change History (46)

comment:1 Changed 16 months ago by chaider

r17608 Initialized branch

comment:2 Changed 16 months ago by chaider

  • Status changed from new to accepted

r17609 Added DataAnalysis.Symbolic.Regression

comment:3 Changed 16 months ago by chaider

r17611 Added ConstraintAnalyzer

comment:4 Changed 16 months ago by chaider

r17621 Added single objective evaluators

comment:5 Changed 16 months ago by chaider

r17623 Added multi objective analyzer and evaluators

comment:6 Changed 16 months ago by chaider

r17627

  • Added abstract class for splitting parameters
  • Fixed formatting

comment:7 Changed 16 months ago by chaider

r17632 Changed readonly dictionary to normal dicitionary to set new interval in VariableRanges after splitting the intervals

comment:8 Changed 16 months ago by chaider

r17636 Changed variable ranges to be readonly

comment:9 Changed 16 months ago by chaider

r17652 Persistence fixes and small changes

comment:10 Changed 16 months ago by chaider

r17653 Added NMSESingleObjectiveEvaluator

comment:11 Changed 16 months ago by chaider

r17660

  • Set worst nmse value to 1.0 in SymbolicRegressionSingleObjectiveConstraintConstOptNmseEvaluator
  • Added SymbolicRegressionSingleObjectiveConstraintScalingNmseEvaluator which allows to use linear scaling within IA

comment:12 Changed 15 months ago by chaider

r17705

  • Fixed some formating in SymbolicRegressionSingleObjectiveConstraintScalingNmseEvaluator
  • Added linear scaling check in SymbolicRegressionSingleObjectiveConstraintScalingNmseEvaluator
  • Added linear scaling for SymbolicRegressionMultiObjectiveMultiSoftConstraintEvaluator

comment:13 Changed 15 months ago by dpiringe

r17722

  • added parameter support for dimensions
  • added region calculation in SymbolicRegressionConstraintAnalyzer

comment:14 Changed 14 months ago by dpiringe

r17733

  • modified SymbolicRegressionConstraintAnalyzer to calculate an error (as out parameter)
    • added an ILookupParameter to write a penality multiplier into the scope
  • changed a lot of evaluators to match the changed analyzer method
  • changed SymbolicRegressionSingleObjectiveConstraintConstOptNmseEvaluator to use a rising penality (instead of setting an unsatisfied solution to 1.0)

comment:15 Changed 14 months ago by dpiringe

r17734

  • method Calculate (QuadraticDiscreteDoubleValueModifier) was renamed to Apply

comment:16 Changed 14 months ago by dpiringe

r17735

  • added a IResultParameter to show the rising penality
  • added a IValueParameter to set the step size (enables plateaus with the same penality multiplier)

comment:17 Changed 14 months ago by chaider

r17743 Added parameter to use smart splitting and extended constraint checking method for splitting

comment:18 Changed 13 months ago by chaider

r17744 Removed Pearson R² Evaluators and added a new single-objective configurable evaluator

comment:19 Changed 13 months ago by chaider

r17750 Moved the linear scaling condition

comment:20 Changed 13 months ago by chaider

r17751 Added Splitting-Parameter

comment:21 Changed 13 months ago by chaider

r17761 Removed splitting direction parameter

comment:22 Changed 13 months ago by chaider

r17764

  • Removed UseSplitting parameter from analyzer
  • Added BoundEstimatorParameter to evaluator

comment:23 Changed 13 months ago by dpiringe

r17766

  • changed the relevant code in SymbolicRegressionConstraintAnalyzer for the new class Region
  • added the .editorconfig file from trunk (to satisfy the coding guidelines)
Last edited 13 months ago by dpiringe (previous) (diff)

comment:24 Changed 13 months ago by chaider

r17769

  • Added parameter for estimator
  • Used IntervalUtil methods for the constraint checking

comment:25 Changed 13 months ago by dpiringe

r17771

  • added a new analyzer (and an abstract base class) for finding the best meta model for multiple datasets

comment:26 Changed 13 months ago by chaider

r17774 Checked for infinity or NaN values in multi objective evaluator

comment:27 Changed 12 months ago by dpiringe

r17776:

  • changed SymbolicRegressionSingleObjectiveMetaModelAnalyzer to calculate the average quality of an solution for all problems
    • average: because we need to include outlier
  • some architectural changes
  • added new (but empty) meta model analyzer for multi objective -> SymbolicRegressionMultiObjectiveMetaModelAnalyzer

comment:28 Changed 11 months ago by chaider

r17789 Merged trunk into branch

comment:29 Changed 10 months ago by dpiringe

r17792

  • updated SymbolicRegressionSingleObjectiveMetaModelAnalyzer to find a meta model with and without constant optimization
  • added a new result parameter of type DataTable in SymbolicRegressionConstraintAnalyzer to show the absolute number of unsatisfied individuals
  • added soft constraints handling for SymbolicRegressionSingleObjectiveConstraintEvaluator

comment:30 Changed 10 months ago by gkronber

TODOs before reintegration:

  • Remove MetaModel stuff
  • Remove SplittingEvaluator (and adapt derived class)
  • Remove MultiObjectiveHardConstraintEvaluator
  • Remove MultiObjectiveConstraintsAnalyzer
  • Remove PenaltyWeighting from SymRegConstraintAnalyzer

comment:31 Changed 10 months ago by chaider

r17794 Removed SplittingEvaluator and MultiObjectiveConstraintAnalyzer

comment:32 Changed 10 months ago by chaider

r17795 Removec MultiObjectiveConstraintAnalyzer

comment:33 Changed 9 months ago by chaider

r17821 Refactoring Evaluators and Analyzers

comment:34 Changed 8 months ago by gkronber

r17877: merged r17817 from trunk to branch

comment:35 Changed 8 months ago by chaider

r17878 Removed unused code

comment:36 Changed 8 months ago by chaider

r17879 Removed MultiHardConstraintEvaluator

comment:37 Changed 8 months ago by chaider

r17882 Fixed description in MultiSoftConstraintEvaluator

comment:38 Changed 8 months ago by chaider

r17883 renamed branch

comment:39 Changed 8 months ago by chaider

r17884 copied reintegration branch to keep splitting code (which will be removed in the reintegration branch)

comment:40 Changed 8 months ago by gkronber

TODO:

  • Adjust headers
Last edited 7 months ago by gkronber (previous) (diff)

comment:41 Changed 8 months ago by gkronber

r17892: refactoring to prepare for trunk reintegration

comment:42 Changed 7 months ago by chaider

r17897 fixed a compilation error (to work with latest version of 3073)

comment:43 Changed 7 months ago by chaider

r17898 refactoring to prepare for branch reintegration

comment:44 Changed 7 months ago by chaider

r17903 merged reintegration branch to trunk

comment:45 Changed 7 months ago by chaider

r17904 deleted reintegration branch

comment:46 Changed 3 months ago by gkronber

  • Resolution set to obsolete
  • Status changed from accepted to closed
  • Version changed from branch to trunk

Has been merged to trunk together with #3073. Further activities tracked in #3073.

Note: See TracTickets for help on using tickets.