Opened 3 months ago

Closed 3 days ago

#3051 closed defect (done)

Synchronization issue of data members with [ThreadStatic] attribute in Batch and Native interpreters

Reported by: bburlacu Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.17
Component: Problems.DataAnalysis.Symbolic Version: trunk
Keywords: Cc:

Description

The two data members in question cachedData and dataset are not marked as static, therefore the [ThreadStatic] attribute has no effect. This causes issues when the runtime reuses threads, in which case the data becomes out of sync.

Change History (5)

comment:1 Changed 3 months ago by bburlacu

  • Status changed from new to accepted

comment:2 Changed 3 months ago by bburlacu

  • Owner changed from bburlacu to mkommend
  • Status changed from accepted to reviewing

r17402: Correctly add static attribute.

comment:3 Changed 2 months ago by mkommend

  • Status changed from reviewing to readytorelease

Reviewed changes in r17402.

The changes look good, but I couldn't verify that all issues are resolved due to difficulties in reproducing the bug.

comment:4 Changed 3 days ago by mkommend

r17497: Merged r17402 into stable.

comment:5 Changed 3 days ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.