Free cookie consent management tool by TermsFeed Policy Generator

Opened 3 years ago

Closed 2 years ago

#3038 closed defect (done)

Residual Analysis does not display data points outside of training and test

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.17
Component: Problems.DataAnalysis.Views Version:
Keywords: Cc:

Description

There can be additional data present that is neither used for training or testing of generated models. However, these data points are not generated within the residual analysis views and thus cannot be displayed although they are visible in every other regression solution view.

Change History (8)

comment:1 Changed 3 years ago by mkommend

  • Status changed from new to accepted

r17341: Added data points outside of training and test to the residual analysis.

comment:2 Changed 3 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

Please review r17341.

IMHO the filter in line 90-94 is more confusing than helpful, because variables are not displayed and cannot be chosen. What is your opinion?

comment:3 Changed 3 years ago by gkronber

  • Owner changed from gkronber to mkommend

Reviewed r17341. Filtering of 'constant variables' can be removed in lines 90-94 if you think it's better. I remember that I had a case with many 'constant variables' in a dataset and therefore added the filtering.

comment:4 Changed 3 years ago by mkommend

  • Owner changed from mkommend to gkronber

r17539: Removed filtering of variables with only one distinct value in ResidualAnalysisView.

comment:5 Changed 2 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to readytorelease

Reviewed r17341 and r17539.

comment:6 Changed 2 years ago by gkronber

r17808: merged r17341 and r17539 from trunk to stable

comment:7 Changed 2 years ago by gkronber

  • Version trunk deleted

comment:8 Changed 2 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.