Opened 20 months ago

Closed 4 months ago

#2973 closed defect (done)

Maximizing VariableImpactView shows no data

Reported by: fholzing Owned by: mkommend
Priority: low Milestone: HeuristicLab 3.3.17
Component: Problems.DataAnalysis.Symbolic.Views Version: trunk
Keywords: Cc:

Description (last modified by fholzing)

Reproduce as follows: Create Random Forest Regression for a reasonable large dataset (Tower). Open the Variable Impacts in the Random Forest Regression Solution. The data will show. Now double-click on the Variable Impacts entry in the Regression Solution. The View will maximize, but no data will be displayed.

Attachments (1)

ProgressDisposing.patch (10.7 KB) - added by pfleck 7 months ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 20 months ago by fholzing

  • Description modified (diff)
  • Status changed from new to accepted

comment:2 Changed 20 months ago by fholzing

  • Description modified (diff)

comment:3 Changed 16 months ago by fholzing

  • Milestone changed from HeuristicLab 3.3.16 to HeuristicLab 3.3.17

comment:4 Changed 16 months ago by fholzing

  • Version trunk deleted

comment:5 Changed 11 months ago by fholzing

r17276: Changed cancelation-initiation from VisibleChanged to OnHidden and added a flag, preventing an error in case the View gets closed.

comment:6 Changed 11 months ago by fholzing

  • Version set to trunk

comment:7 Changed 10 months ago by fholzing

  • Owner changed from fholzing to pfleck
  • Status changed from accepted to reviewing

comment:8 Changed 8 months ago by pfleck

  • Owner changed from pfleck to fholzing
  • Status changed from reviewing to assigned

Tested r17276 and it works.

However, I also tried a simpler solution to the problem, by only triggering the cancellation token within RegressionSolutionVariableImpactsView_VisibleChanged (line 88) if this.Visible is false. Could you test if this solution has any drawbacks that I am not thinking of?

Changed 7 months ago by pfleck

comment:9 Changed 7 months ago by pfleck

@fholzing, I attached a patch that hopefully fixes the progress disposing issue. Please check if you can still produce any exceptions when applying the patch (to the stable).

comment:10 Changed 6 months ago by pfleck

r17426

  • Certain events of the TargetControl are now forwarded to the ProgressView in order to correctly dispose and hide the ProgressView.
  • Simplified hiding the ProgressView within the Regression/ClassificationSolutionVariableImpactsView.

I could not reproduce any of the tickets issues. However, I still managed to get a "long lasting" progress bar for when optimizing a symbolic expression tree within the simplifier. I will look further into this, why the progress bar is sometimes lingering that long, even after cancelling the operation.

comment:11 Changed 6 months ago by pfleck

r17430

  • Fixed progress calculation for InteractiveSymbolicDataAnalysisSolutionSimplifierView.
  • Added a minimum improvement (of 1E-10) to stop constant opt.
  • Added tooltips for Simplify and Optimize.

Concerning reducing the repetitions for constant opt to 100 (instead of 1000): In #2844, it was stated that it should not be necessary to click the optimize button multiple times, thus the high repetition count. However, if we want to show a meaningful progressbar, having such a high number of repetitions would lead to a very slow progress that will prematurely close anyway due to convergence of the algorithm. After discussion with mkommenda, we opted for reducing the number of repetitions in favor of a reasonable progress indication.

comment:12 Changed 4 months ago by fholzing

I retested both the initial issue concerning the missing data when maximizing the VariableImpactView and the new behaviour of the ConstOpt/ProgressBar. No issues occured, neither for Regression- nor Classification-solutions. Seems to work like a charm.

Just one very minor remark: I highly approve the tooltips! Maybe the simplify tooltip should also be added to the SymbolicClassificationSolutionView and SymbolicRegressionSolutionView (btnSimplify) instead of the generic "Simplify solution" tooltip?

comment:13 Changed 4 months ago by fholzing

  • Owner changed from fholzing to mkommend
  • Status changed from assigned to reviewing

comment:14 Changed 4 months ago by mkommend

r17488: Updated tooltip for simplify button in all symbolic data analysis solution views.

comment:15 Changed 4 months ago by mkommend

  • Status changed from reviewing to readytorelease

Reviewed r17276, r17426, r17430, r17488.

Merge problems might occur in connection with #3042.

comment:16 Changed 4 months ago by mkommend

r17500: Merged r17276, r17426, r17430, r17488 into stable.

comment:17 Changed 4 months ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.