Opened 2 years ago

Closed 2 years ago

Last modified 19 months ago

#2819 closed enhancement (duplicate)

Long running operations in the Simplification View freeze HL

Reported by: pfleck Owned by: pfleck
Priority: medium Milestone:
Component: Problems.DataAnalysis.Symbolic.Views Version: 3.3.14
Keywords: Cc:

Description

Optimizing a SymbolicRegressionSolution with the InteractiveSymbolicRegressionSolutionSimplifierView freezes HL for the duration of the constant-optimization.

For smaller models/datasets, this is not an issue. However, it is annoying for larger models/datasets when HL freezes for several seconds (or even minutes). Instead, the calculations should be done in a different thread and a progress reported if available.

The following actions notably causes HL to freeze:

  • "Optimize"/"Simplify"-Buttons in the InteractiveSymbolicXXXSolutionSimplifierView
  • "Simplify Model"-Button in the SymbolicXXXSolutionView

Change History (4)

comment:1 Changed 2 years ago by pfleck

  • Status changed from new to accepted

comment:2 Changed 2 years ago by mkommend

  • Summary changed from SymReg-Simplifier freezes HL to Long running operations in the Simplification View freeze HL

comment:3 Changed 2 years ago by pfleck

  • Resolution set to duplicate
  • Status changed from accepted to closed

Duplicate of #1666

comment:4 Changed 19 months ago by abeham

  • Milestone HeuristicLab 3.3.16 deleted
Note: See TracTickets for help on using tickets.