Opened 4 months ago

Closed 2 months ago

#2790 closed defect (done)

Island GA throws exception when applied to JSSP

Reported by: abeham Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.15
Component: Problems.Scheduling Version: 3.3.14
Keywords: Cc:

Description

The random parameter of the decoder is not configured correctly. It should be configured to LocalRandom. The algorithm probably doesn't see this operator as it's not part of the problem's operator collection.

Change History (7)

comment:1 Changed 3 months ago by mkommend

  • Owner set to abeham
  • Status changed from new to assigned

comment:2 Changed 3 months ago by abeham

  • Status changed from assigned to accepted

comment:3 Changed 3 months ago by abeham

  • Owner changed from abeham to pfleck
  • Status changed from accepted to reviewing

r15072: added decoder to operators

comment:4 Changed 3 months ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from reviewing to assigned

reviewed r15072:

Since the Decoder is added as a "regular operator", it is configured "regularly" and the GlobalRandom is used. Because the decoder is called during the evaluation - which might be called in parallel - the LocalRandom should be used instead. Otherwise, we get race conditions and results are not reproducible. The same is also true for ALPS.

comment:5 Changed 3 months ago by abeham

  • Owner changed from abeham to pfleck
  • Status changed from assigned to reviewing

r15083:

  • Fixed small bug in JSSP where solution creator changed was not fired
  • Added IStochasticOperator to SchedulingEvaluator and added backwards compatibility code

comment:6 Changed 3 months ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from reviewing to readytorelease

r15083: Tested and works now for Island-GA and ALPS

comment:7 Changed 2 months ago by abeham

  • Resolution set to done
  • Status changed from readytorelease to closed

r15219: merged revisions 15072, 15083, 15168 to stable

Note: See TracTickets for help on using tickets.