Opened 2 years ago

Closed 2 years ago

#2669 closed defect (done)

TargetVariable information is lost in DataAnalysisModels

Reported by: mkommend Owned by: mkommend
Priority: high Milestone: HeuristicLab 3.3.15
Component: Problems.DataAnalysis Version: 3.3.14
Keywords: Cc:

Description

With r13992 the target variable has been set to string.Empty. This has been implemented to avoid NullReferenceExceptions. However, the side effect has been that without a guarding if clause any saved target variable will be overwritten with an empty string causing a persistence break (e.g. SVM models).

Change History (7)

comment:1 Changed 2 years ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 2 years ago by mkommend

r14289: Removed the after deserialization method that resets the targetVariable. Instead the initialization code has been added to the storable ctor.

comment:3 Changed 2 years ago by mkommend

There could still be a persistence break for models that have been reopened and saved with an revision between r13992 and r14289 because the target variable has been lost for those.

comment:4 Changed 2 years ago by bburlacu

r14290: Added setter for the TargetVariable property in the classification and regression model interfaces and adjusted implementing classes accordingly. Similarly, added a TargetVariableChanged event to the models.

comment:5 Changed 2 years ago by mkommend

  • Status changed from accepted to reviewing

comment:6 Changed 2 years ago by mkommend

  • Status changed from reviewing to readytorelease

Reviewed r14289 and r14290.

comment:7 Changed 2 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed

r14571: merged r14289 and r14290 from trunk to stable

Note: See TracTickets for help on using tickets.