Opened 3 years ago

Closed 21 months ago

#2622 closed enhancement (duplicate)

Handle missing values (i.e. NaN) correctly when training GBT models

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.x Backlog
Component: Algorithms.DataAnalysis Version: 3.3.13
Keywords: Cc:

Description

Right now GBT training only uses comparison operators and assumes that there are no missing values in the input variables. This is not really correct as NaN values are assigned to either the left or the right subtree. Instead those observations should be ignored in the training phase.

This ticket is related to #2612.

Change History (3)

comment:1 Changed 3 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.15 to HeuristicLab 3.3.x Backlog

comment:2 Changed 2 years ago by gkronber

Duplicate of #2613?

comment:3 Changed 21 months ago by gkronber

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, this is a duplicate.

Note: See TracTickets for help on using tickets.