Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2617 closed defect (worksforme)

Local search seems to perform differently for single-objective test functions and programmable problems

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone:
Component: Problems.TestFunctions Version: 3.3.13
Keywords: Cc:

Description

Reproduce:

  1. Run local search or simulated annealing with 10-dim Rastrigin (test function)
  2. Create programmable problem and implement evaluation function for Rastrigin
  3. Implement neighborhood method (add Gaussian to one element) (check additive move generator in test functions)
  4. Run local search or simulated annealing --> completely different convergence behaviour

Especially alarming is the facts at local search always converges to the global optimum for the multi-modal Rastrigin function (?!)

Attachments (1)

10d rastrigin.hl (41.8 KB) - added by abeham 3 years ago.
programmable problem implementing the 10d rastrigin test function

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by abeham

I can't reproduce this behavior. Both LS on a programmable problem as well as on the test function implementation converge to about Xe-05 within 1000 iterations and 100 samples.

Please be so kind and attach the hl file with your programmable problem. I suspect you used different bounds (original bounds are [-5.12 ; 5.12 ] for every dimension).

Rastrigin, while highly multi-modal, is still a separable problem.

Changed 3 years ago by abeham

programmable problem implementing the 10d rastrigin test function

comment:2 Changed 3 years ago by gkronber

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for testing this and for preparing the demo problem implementation.

comment:3 Changed 3 years ago by abeham

  • Milestone HeuristicLab 3.3.14 deleted
Note: See TracTickets for help on using tickets.