Opened 2 years ago

Closed 2 years ago

#2493 closed defect (done)

Editing labels in the experiment (tree) view don't update the respective item's name

Reported by: abeham Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.13
Component: Optimization.Views Version: 3.3.12
Keywords: Cc:

Description

To reproduce:

  1. Create a new experiment
  2. Add a new genetic algorithm
  3. Click on the name of the genetic algorithm in the tree view
  4. Change the name

After step 4 you will have the old name present in the algorithm view on the right and the new name in the tree view. It seems that editing the label doesn't have any effect besides changing the label.

Change History (5)

comment:1 Changed 2 years ago by mkommend

  • Owner set to mkommend
  • Status changed from new to accepted

comment:2 Changed 2 years ago by mkommend

Changing of labels in the experiment tree view has been originally implemented, but was discarded because of complications with the display of batch run repititions (#1043 - r8726). However, it seems I was a bit sloppy and haven't disabled it completely.

comment:3 Changed 2 years ago by mkommend

  • Owner changed from mkommend to abeham
  • Status changed from accepted to reviewing

r13143: Removed functionality to edit labels in the ExperimentTreeView.

comment:4 Changed 2 years ago by abeham

  • Owner changed from abeham to mkommend
  • Status changed from reviewing to readytorelease

ok

comment:5 Changed 2 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed

r13178: Merged r13143 into stable.

Note: See TracTickets for help on using tickets.