Opened 2 years ago

Closed 2 years ago

#2452 closed defect (done)

Support drag&drop of new solutions in the RegressionSolutionErrorCharacteristicsCurveView

Reported by: bburlacu Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.13
Component: Problems.DataAnalysis Version: 3.3.12
Keywords: Cc:

Description

When new solutions are dropped on the chart area, their respective error characteristic curves should be added. Attached patch which implements this. Question: how to handle solutions where the problem data is different than the current problem data?

Attachments (1)

error-characteristics-chart-drag-and-drop.patch (3.9 KB) - added by bburlacu 2 years ago.
Patch to implement drag&drop

Download all attachments as: .zip

Change History (13)

Changed 2 years ago by bburlacu

Patch to implement drag&drop

comment:1 Changed 2 years ago by bburlacu

  • Status changed from new to accepted
  • Summary changed from Support drag&drop of new solutions in the RegressionErrorCharacteristicsCurveView to Support drag&drop of new solutions in the RegressionSolutionErrorCharacteristicsCurveView

comment:2 Changed 2 years ago by bburlacu

  • Owner changed from bburlacu to mkommend
  • Status changed from accepted to reviewing

comment:3 Changed 2 years ago by mkommend

  • Owner changed from mkommend to gkronber

comment:4 Changed 2 years ago by gkronber

r13002: applied Bogdan's patch to the trunk.

comment:5 Changed 2 years ago by gkronber

Issues that should still be improved:

  • Solutions that are added to the view are lost when the chart series are cleared (only the series are added)
  • No data type check for items dragged onto the view
  • It is not possible to add results containing a regression solution onto the view

comment:6 Changed 2 years ago by gkronber

r13003: refactored RegressionSolutionErrorCharacteristicsCurveView to better support comparison of a set of solutions in one chart (via drag&drop)

comment:7 Changed 2 years ago by gkronber

Would be great if we could rename regression solutions... This actually works, I was confused because the result was locked (cloning the solution works).

Last edited 2 years ago by gkronber (previous) (diff)

comment:8 Changed 2 years ago by gkronber

r13004: changed plugin dependencies

comment:9 Changed 2 years ago by gkronber

  • Owner changed from gkronber to mkommend

comment:10 Changed 2 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

Reviewed r13002, r13003 and r13003.

comment:11 Changed 2 years ago by gkronber

r13062: merged r13002:13004 from trunk to stable

comment:12 Changed 2 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.