Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#240 closed defect (done)

DatasetView hangs when updating the data-grid (after import)

Reported by: gkronber Owned by: gkronber
Priority: highest Milestone: HeuristicLab 3.3.0
Component: ZZZ OBSOLETE: DataAnalysis Version: 3.1
Keywords: Cc:

Description

Importing new data causes the DatasetView to hang while updating the grid view with 100% CPU load.

Change History (7)

comment:1 Changed 11 years ago by gkronber

  • Status changed from new to assigned

comment:2 Changed 11 years ago by gkronber

The hang appears to happen inside DataGrid when increasing the number of rows.

comment:3 Changed 11 years ago by gkronber

This was caused by the auto-resizing of row headers introduced with r458. Disabled the auto-resizing with r472.

comment:4 Changed 11 years ago by gkronber

  • Resolution set to fixed
  • Status changed from assigned to closed

r473 reactivated auto-resizing of header cells by disabling resizing before updating the content of the DataGrid and enabling resizing again afterwards.

This solution is very similar to an earlier problem we had with the auto-layout of DataGrid (see #157). I guess we have to live with the fact that the layout of DataGrid has a few issues.

comment:5 Changed 10 years ago by swagner

  • Milestone changed from 3.1 to Iteration 0

Milestone 3.1 deleted

comment:6 Changed 9 years ago by swagner

  • Milestone changed from Iteration 0 to Current

Milestone Iteration 0 deleted

comment:11 Changed 9 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.