Opened 3 years ago

Closed 2 years ago

#2354 closed defect (done)

Statistical tests view throws exception before opening

Reported by: abeham Owned by: ascheibe
Priority: medium Milestone: HeuristicLab 3.3.12
Component: Analysis.Statistics.Views Version: 3.3.11
Keywords: Cc:

Description

To reproduce:

  • Open GA-TSP sample
  • Change MaximumGenerations to 10, change PopulationSize to 10
  • Make 6 runs
  • Change PopulationSize to 20
  • Make 6 runs
  • Open statistical tests view on RunCollection

In my case I got this exception and the view didn't open:

System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at System.Collections.Generic.List`1.get_Item(Int32 index)
   at HeuristicLab.Analysis.Views.HistogramControl.CalculateDensity(Series series, List`1 row, Double bandwidth) in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Views\3.3\HistogramControl.cs:line 199
   at HeuristicLab.Analysis.Views.HistogramControl.UpdateHistogram(Double bandwith) in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Views\3.3\HistogramControl.cs:line 180
   at HeuristicLab.Analysis.Views.HistogramControl.AddPoints(String name, IEnumerable`1 points, Boolean replace) in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Views\3.3\HistogramControl.cs:line 119
   at HeuristicLab.Analysis.Statistics.Views.StatisticalTestsView.GenerateChart(DataTable histogramTable) in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Statistics.Views\3.3\StatisticalTestsView.cs:line 232
   at HeuristicLab.Analysis.Statistics.Views.StatisticalTestsView.RebuildDataTable() in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Statistics.Views\3.3\StatisticalTestsView.cs:line 226
   at HeuristicLab.Analysis.Statistics.Views.StatisticalTestsView.groupComboBox_SelectedValueChanged(Object sender, EventArgs e) in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Statistics.Views\3.3\StatisticalTestsView.cs:line 269
   at System.Windows.Forms.ComboBox.OnSelectedValueChanged(EventArgs e)
   at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
   at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
   at HeuristicLab.Analysis.Statistics.Views.StatisticalTestsView.OnContentChanged() in c:\SomePath\HL3\stable\HeuristicLab.Analysis.Statistics.Views\3.3\StatisticalTestsView.cs:line 80
   at HeuristicLab.MainForm.WindowsForms.ContentView.set_Content(IContent value) in c:\SomePath\HL3\stable\HeuristicLab.MainForm.WindowsForms\3.3\Views\ContentView.cs:line 52
   at HeuristicLab.MainForm.WindowsForms.ViewHost.OnContentChanged() in c:\SomePath\HL3\stable\HeuristicLab.MainForm.WindowsForms\3.3\Controls\ViewHost.cs:line 149
   at HeuristicLab.MainForm.WindowsForms.ContentView.set_Content(IContent value) in c:\SomePath\HL3\stable\HeuristicLab.MainForm.WindowsForms\3.3\Views\ContentView.cs:line 52
   at HeuristicLab.MainForm.WindowsForms.MainForm.ShowContent(IContent content, Type viewType) in c:\SomePath\HL3\stable\HeuristicLab.MainForm.WindowsForms\3.3\MainForms\MainForm.cs:line 261
   at HeuristicLab.Optimization.Views.RunCollectionView.menuItem_Click(Object sender, EventArgs e) in c:\SomePath\HL3\stable\HeuristicLab.Optimization.Views\3.3\RunCollectionViews\RunCollectionView.cs:line 349
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Change History (7)

comment:1 Changed 3 years ago by ascheibe

  • Status changed from new to accepted

r12173 fixed bug in HistogramControl when the interval is zero

comment:2 Changed 3 years ago by ascheibe

  • Owner changed from ascheibe to abeham
  • Status changed from accepted to reviewing

comment:3 Changed 3 years ago by abeham

  • Owner changed from abeham to ascheibe
  • Status changed from reviewing to assigned

The histogram page now is just empty. The legend is displayed, but no chart is actually drawn. Please put a message on the view that displays the reason for the missing chart...

Take a look at the bubble chart for example. A similar message is displayed there when you first open it.

comment:4 Changed 3 years ago by ascheibe

  • Status changed from assigned to accepted

r12458 show label when no data is displayed and don't show the legend

comment:5 Changed 3 years ago by ascheibe

  • Owner changed from ascheibe to abeham
  • Status changed from accepted to reviewing

comment:6 Changed 2 years ago by abeham

  • Owner changed from abeham to ascheibe
  • Status changed from reviewing to readytorelease

Tested the functionality, it works. I think we may run into a merge conflict with ticket #2270. They should be released together.

comment:7 Changed 2 years ago by ascheibe

  • Resolution set to done
  • Status changed from readytorelease to closed
Note: See TracTickets for help on using tickets.