Opened 3 years ago

Closed 2 years ago

#2301 closed enhancement (done)

Improve numeric accuracy in create experiment dialog

Reported by: abeham Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.12
Component: Optimizer Version: 3.3.10
Keywords: Cc:

Description (last modified by pfleck)

Move the ValueGenerator* to HeuristicLab.Common, or another suitable and accessible place and use it in the create experiment dialog to avoid accuracy problems.

In order to move the ValueGenerator to the Common plugin, the methods for generating normal distributed values are moved to the the NormalDistributedRandom class in the Random plugin.

*trunk/sources/HeuristicLab.Problems.Instances.DataAnalysis/3.3/Regression/ValueGenerator.cs

Change History (8)

comment:1 Changed 2 years ago by mkommend

  • Owner set to pfleck
  • Status changed from new to assigned

comment:2 Changed 2 years ago by pfleck

  • Status changed from assigned to accepted

comment:3 Changed 2 years ago by pfleck

  • Description modified (diff)

comment:4 Changed 2 years ago by pfleck

r12292 Removed the GenerateSteps from the ValueGenerator and put it into the new SequenceGenerator. Adapted DataAnalysis-Instances and scripts (samples and unit tests).

comment:5 Changed 2 years ago by pfleck

r12293 Use decimal instead of double for the DefineArithmeticProgressionDialog and in the CreateExperimentDialog. Note, when using decimal only during the generate process but not during some calculations (e.g. determining meaningful step sizes), numeric inaccuracies occur. Therefore some calculations now uses decimal instead of double values.

comment:6 Changed 2 years ago by pfleck

  • Owner changed from pfleck to abeham
  • Status changed from accepted to reviewing

mkommenda and I also discussed, moving the GenerateUniformDistributedValues and GenerateNormalDistributedValues to appropriate location in the Random-plugin.

Because the ValueGenerator produces values in a slightly different format and range than the usual implementation would, we decided not to move those methods. For instance, GenerateUniformDistributedValues includes the maximum value.

comment:7 Changed 2 years ago by abeham

  • Status changed from reviewing to readytorelease

Reviewed the changes, thanks for implementing this

comment:8 Changed 2 years ago by abeham

  • Resolution set to done
  • Status changed from readytorelease to closed

r12740: merged 12292,12293 to stable

Note: See TracTickets for help on using tickets.