Opened 5 years ago

Closed 5 years ago

#2186 closed feature request (duplicate)

Boosting Meta-Algorithm

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.x Backlog
Component: Algorithms.DataAnalysis Version: 3.3.9
Keywords: Cc:

Description

AdaBoost with sampling instead of weighting could be implemented for classification problems.

Friedmans "Stochasic Gradient Boosting" (1999) could be implemented for regression and classification problems.

One important question is where the gradient for our target functions is implemented. In gradient boosting we need to use the correct gradient which is appropriate for the currently selected fitness function.

Change History (2)

comment:1 Changed 5 years ago by gkronber

  • Summary changed from Boosting MetaAlgorithm to Boosting Meta-Algorithm

comment:2 Changed 5 years ago by gkronber

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of 1795

Note: See TracTickets for help on using tickets.