Opened 10 years ago

Closed 9 years ago

#1964 closed enhancement (done)

Symbolic Regression and Classification Solutions do not indicate if EstimationLimits are hit

Reported by: mkommend Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.8
Component: Problems.DataAnalysis.Symbolic Version: 3.3.8
Keywords: Cc:

Description

A new result showing the number of evaluations which hit the estimation limit or result in null should be added to the SymbolicRegression- and SymbolicClassificationSolutions.

Change History (11)

comment:1 Changed 10 years ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 10 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

r8723: Added new results to symbolic classification and regression solutions. Additionally, the way results are calculated was refactored and unified.

Regarding the result calculation:

  • Virtual method calls to RecalculateResults were removed from ctors.
  • Calls to RecalculateResults now first call the base implementation.
  • Solution base classes do not calculate the results, but provide protected method calls which should be called from directly derived classes.

comment:3 Changed 10 years ago by mkommend

  • Owner changed from gkronber to mkommend
  • Status changed from reviewing to assigned

Apparently there is a problem with ensemble solutions.

comment:4 Changed 10 years ago by mkommend

  • Status changed from assigned to accepted

comment:5 Changed 10 years ago by mkommend

r8724: Corrected creation of ensemble solutions.

comment:6 Changed 10 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

comment:7 Changed 10 years ago by gkronber

Reviewed r8723:8724. I think we are unnecessarily calling RecalculateResults() in the constructors of RegressionSolutions because this is already done in the constructor of RegressionSolution.

Last edited 10 years ago by gkronber (previous) (diff)

comment:8 Changed 10 years ago by gkronber

r8837: removed call to RecalculateResults in the ctor of solutions derived from RegressionSolution

comment:9 Changed 10 years ago by gkronber

  • Owner changed from gkronber to mkommend

Please review r8837 and set ticket to ready-to-release if OK.

comment:10 Changed 10 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

r8837 is fine. I have forgotten to adapt all regression solutions apparently.

comment:11 Changed 9 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.7 to 3.3.8
Note: See TracTickets for help on using tickets.