Opened 7 years ago

Closed 7 years ago

#1861 closed task (obsolete)

Port HeuristicLab to Mono

Reported by: ascheibe Owned by: ascheibe
Priority: medium Milestone:
Component: General Version: 3.3.6
Keywords: Cc:

Description

Enclosed to this ticket is a file containing 83 patches which make HeuristicLab work with Mono (thanks to Daniel Knittl-Frank). This ticket is for tracking the integration of these patches into the official HL sources.

There are still a few problems with Mono itself:

  • A NullReferenceException in Mono's Threading implementation prevents Pausing/Stopping of algorithms.
  • WinForms DataColumn in DataGridView throws an ArgumentOutOfRangeException when using the GetPreferredWidth method.
  • An ObjectDisposedException in the GC because of multiple Dispose calls in the ToolStrip* classes.
  • http://bugzilla.xamarin.com/show_bug.cgi?id=580
  • Drag and Drop sometimes doesn't work (unreproducible).

Attachments (1)

hl-svn-patches.zip (1.8 MB) - added by ascheibe 7 years ago.

Download all attachments as: .zip

Change History (26)

Changed 7 years ago by ascheibe

comment:1 Changed 7 years ago by ascheibe

  • Status changed from new to accepted

comment:2 Changed 7 years ago by ascheibe

r8365 created branch for HeuristicLab Mono port

comment:3 Changed 7 years ago by ascheibe

r8370 applied patch 0004 and fixed project references

comment:4 Changed 7 years ago by ascheibe

r8373 fixed ziplib references

comment:5 Changed 7 years ago by ascheibe

r8374 applied patch 0005 and 0059

comment:6 Changed 7 years ago by ascheibe

r8376 added script for copying assemblies to bin

comment:7 Changed 7 years ago by ascheibe

r8383 updated copy assembly script

comment:8 Changed 7 years ago by ascheibe

r8389 changed HeuristicLab project file to be able to use it as startup project

comment:9 Changed 7 years ago by ascheibe

r8393 applied patch 0062

comment:10 Changed 7 years ago by ascheibe

r8394 applied patch 0082

comment:11 Changed 7 years ago by ascheibe

r8440 made prebuild events os dependent

comment:12 Changed 7 years ago by ascheibe

r8442 applied patches 0014 and 0015

comment:13 Changed 7 years ago by ascheibe

r8443 applied patch 0016

comment:14 Changed 7 years ago by ascheibe

r8444 removed ProtocolBuffers from ExtLibs solution because the Mono compiler crashes when compiling it

comment:15 Changed 7 years ago by ascheibe

r8445 applied patch 0018

comment:16 Changed 7 years ago by ascheibe

r8446 fixed some more filenames and applied patch 0017

comment:17 Changed 7 years ago by ascheibe

r8449 fixed mono compiler confusion with HL Random and System.Random

comment:18 Changed 7 years ago by ascheibe

r8450 some more renames and made post build event plattform-dependent

comment:19 Changed 7 years ago by ascheibe

r8451 merged changes from trunk into branch

comment:20 Changed 7 years ago by ascheibe

r8456 fixed Pre and PostBuild events to work on Linux

comment:21 Changed 7 years ago by ascheibe

r8457 applied patches 0021 and 0022

comment:22 Changed 7 years ago by ascheibe

r8500 applied persistence patches

comment:23 Changed 7 years ago by ascheibe

r8585 merged changes from trunk into branch

comment:24 Changed 7 years ago by ascheibe

r8673 removed mono branch as the changes are already in the trunk

comment:25 Changed 7 years ago by ascheibe

  • Milestone HeuristicLab 3.3.x Backlog deleted
  • Resolution set to obsolete
  • Status changed from accepted to closed

I'm closing this ticket because the changes have already been moved to the trunk (see ticket #1937)

Note: See TracTickets for help on using tickets.