Free cookie consent management tool by TermsFeed Policy Generator

Opened 11 years ago

Closed 10 years ago

#1799 closed defect (done)

DataAnalysisSolutionView throws an exception when switching the details off and on while displaying a chart

Reported by: ascheibe Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.7
Component: Problems.DataAnalysis.Symbolic.Classification.Views Version: 3.3.7
Keywords: Cc:

Description

In the DataAnalysisSolutionView click on Classification Threshold, hide the details and show them again.

The following exception is thrown:

System.InvalidCastException: Unable to cast object of type 'System.RuntimeType' to type 'HeuristicLab.Optimization.IResult'.
   at HeuristicLab.Core.Views.ItemCollectionView`1.showDetailsCheckBox_CheckedChanged(Object sender, EventArgs e)
   at System.Windows.Forms.CheckBox.set_CheckState(CheckState value)
   at System.Windows.Forms.CheckBox.OnClick(EventArgs e)
   at System.Windows.Forms.CheckBox.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Attachments (1)

screenshot.png (219.1 KB) - added by ascheibe 10 years ago.
screenshot of the error

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by ascheibe

  • Owner changed from ascheibe to mkommend
  • Status changed from new to assigned

comment:2 Changed 10 years ago by mkommend

  • Owner changed from mkommend to ascheibe

I could not reproduce the described bug. Please insert a more detailed description and test if this is still an issue.

Changed 10 years ago by ascheibe

screenshot of the error

comment:3 Changed 10 years ago by ascheibe

  • Owner changed from ascheibe to mkommend

Sorry for the vague description. Please have a look at the screenshot. Open the GP classification example and run it. In the Results View click on the Best validation solution. Click the Classification Threshold, then in the second step click on Show/Hide Details. Click the Show/Hide Details again and you should get the error message.

comment:4 Changed 10 years ago by mkommend

  • Status changed from assigned to accepted

comment:5 Changed 10 years ago by mkommend

  • Owner changed from mkommend to ascheibe
  • Status changed from accepted to reviewing

r8125: Corrected behavior in DataAnalysisSolutionView when the visibility of the details is changed.

comment:6 Changed 10 years ago by ascheibe

  • Owner changed from ascheibe to mkommend
  • Status changed from reviewing to readytorelease

I have tested it, works like a charm, thanks!

comment:7 Changed 10 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.