Opened 6 years ago

Closed 5 years ago

#1773 closed feature request (done)

Show symbolic regression or classification models in math notation

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.7
Component: Problems.DataAnalysis.Symbolic.Views Version: 3.3.7
Keywords: Cc:

Description


Change History (15)

comment:1 Changed 6 years ago by gkronber

  • Owner changed from mkommend to gkronber
  • Status changed from new to accepted

comment:2 Changed 6 years ago by gkronber

r7446: added ExtLibs plugin for MathJax and implemented a view for symbolic data analysis models rendering the model in mathematical notation using MathJax in a webbrowser control

comment:3 Changed 6 years ago by gkronber

r7447: set svn:ignore properties

comment:4 Changed 6 years ago by gkronber

r7449: added reference to plugin HeuristicLab.MathJax-1.1 to fix the plugin-dependency checker unit test

comment:5 Changed 6 years ago by gkronber

r7450: removed reference to plugin HeuristicLab.MathJax-1.1 but added mathjax to the list of extlibs to fix the plugin-dependency checker unit test.

comment:6 Changed 6 years ago by gkronber

r7451: fixed bug in the latex formatter, incorrect parentheses for logical or and and operations

comment:7 Changed 6 years ago by gkronber

r7462 %-symbols do not have to be escaped within \text{}.

comment:8 Changed 6 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.7

comment:9 Changed 6 years ago by abeham

I think the default font size is a bit too large. I don't know if this is possible, but it would be nice if formulas could be broken in multiple rows if they're too large (e.g. before or after a term that spans beyond the screen). An additional idea would be to use v0..vn in the formula and have the variables listed in a similar way as the constants (maybe in a second column, or pre- or appending to the constant column). This way it's easy to get a list of all variables in the formula.

comment:10 Changed 6 years ago by gkronber

Line breaking is a bit difficult to get right but should be possible. I don't like idea of using v0 ..vn instead of the variable names a lot.

comment:11 Changed 5 years ago by gkronber

The MathJax script seems to be blocked when HL is started from an USB stick.

comment:12 Changed 5 years ago by gkronber

r8110: switched back to the tree view as default for symbolic data analysis models instead of the math notation view.

comment:13 Changed 5 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:14 Changed 5 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

comment:15 Changed 5 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.