Opened 9 years ago

Closed 7 years ago

#1771 closed feature request (duplicate)

Tree pruning and reductive mutation operators

Reported by: bburlacu Owned by: bburlacu
Priority: low Milestone: HeuristicLab 3.3.x Backlog
Component: Encodings.SymbolicExpressionTreeEncoding Version: 3.3.6
Keywords: Cc:

Description

It would be interesting if the tree pruning (that automatically folds all low impact nodes) could be implemented as an operator (to be applied for instance once every few generations).

Also interesting would be mutation operators that delete a subtree or remove intermediate function nodes.

Change History (3)

comment:1 Changed 9 years ago by gkronber

Related to #1932 (pruning has been implemented for an earlier version in #1142)

comment:2 Changed 8 years ago by gkronber

  • Priority changed from medium to low

comment:3 Changed 7 years ago by bburlacu

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #2143. Reductive mutation operatiors have already been implemented and integrated into the trunk.

Note: See TracTickets for help on using tickets.