Opened 6 years ago

Closed 5 years ago

#1735 closed defect (done)

Symbolic regression problem cannot be dragged onto island algorithms

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.7
Component: Problems.DataAnalysis.Symbolic Version: 3.3.7
Keywords: Cc:

Description

Tested with IslandGA, IslandOSGA, and SASEGASA

Reproduce:

  1. Create new symbolic regression problem
  2. Create new algorithm
  3. Drag problem onto algorithm
  4. Nothing happens

This might effect other problem types as well (most likely symbolic classification)

Change History (5)

comment:1 Changed 6 years ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 6 years ago by mkommend

r7501: Corrected cloning of MinAverageMaxSymbolicExpressionTreeLengthAnalyzer.

The dragging did not work, because the cloning was not implemented correctly. This was only an issue if the depth parameter of the ScopeTreeLookupParameter has to be changed like in the multi population algorithms.

comment:3 Changed 6 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

comment:4 Changed 6 years ago by gkronber

  • Status changed from reviewing to readytorelease

I tested the change and everything works. Thanks for fixing this!

comment:5 Changed 5 years ago by gkronber

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.6 to 3.3.7
Note: See TracTickets for help on using tickets.