Free cookie consent management tool by TermsFeed Policy Generator

Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#168 closed defect (done)

BakedFunctionTree maps different function instances of the same function type to the same symbol

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.0
Component: Functions Version: 3.1
Keywords: Cc:

Description


Change History (9)

comment:1 Changed 16 years ago by gkronber

  • Status changed from new to assigned

comment:2 Changed 16 years ago by gkronber

defect fixed with r317. serialization and evaluation are also effected by the change but are not yet adapted.

comment:3 Changed 16 years ago by gkronber

Adapted and simplified the evaluation code with r318. Removed the possibility to evaluate statically 'unknown' functions. We need a new evaluation scheme for those.

comment:4 Changed 16 years ago by gkronber

simplified the symbol-table mechanism with r319. Most of it wasn't needed anymore after r318 which removed evaluation of 'unknown' functions. This will be handled differently in future revisions.

comment:5 Changed 16 years ago by gkronber

fixed serialization with r320 (was deactivated with r317)

comment:6 Changed 16 years ago by gkronber

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed the main problem of this ticket which was caused by the static mapping of symbols to function-types instead of function-instances (also see #166).

reopened #106 (ProgrammableFunction) and created #169 (extensions to function set) for further changes to make the function evaluation mechanism more flexible.

comment:7 Changed 15 years ago by swagner

  • Milestone changed from 3.1 to Iteration 0

Milestone 3.1 deleted

comment:8 Changed 14 years ago by swagner

  • Milestone changed from Iteration 0 to Current

Milestone Iteration 0 deleted

comment:11 Changed 14 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

Note: See TracTickets for help on using tickets.