Opened 11 years ago

Closed 10 years ago

#1615 closed defect (done)

Changing input variables of data analysis problems is very slow after the algorithm has been executed

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.6
Component: Algorithms.DataAnalysis Version: 3.3.6
Keywords: Cc:

Description


Change History (6)

comment:1 Changed 11 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.6
  • Status changed from new to accepted

comment:2 Changed 11 years ago by gkronber

  • Summary changed from Changing input variables of a regression problem is very slow after nearest-neighbor regression has been executed to Changing input variables of data analysis problems is very slow after the algorithm has been executed

This occurs on multiple different data analysis algorithms

comment:3 Changed 11 years ago by gkronber

r6649: clone problem before creating a solution

comment:4 Changed 11 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:5 Changed 11 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

The usage of the same problem data was the reason why changing the problem data is slowed down. r6649 solves this issue by cloning the problem data, but one has to keep in mind to always use a clone of the problem data when dealing with data analysis solutions.

comment:6 Changed 10 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.5 to 3.3.6
Note: See TracTickets for help on using tickets.