Opened 8 years ago

Closed 4 years ago

#1598 closed defect (obsolete)

The arrow key doesn't respect the currently selected item in the new item dialog

Reported by: abeham Owned by: swagner
Priority: low Milestone:
Component: Optimizer Version: 3.3.5
Keywords: Cc:

Description

Steps to reproduce:

  1. Press Ctrl+N or click the icon to bring up the new item dialog
  2. Create a new item in the middle of the list of algorithms (e.g. NSGA-II) by double clicking it
  3. Bring up the new item dialog once again and you will see the same item be highlighted (also if you press enter the same item will be created again).
  4. Press the down arrow key to try and select the next item

After step 4 the second item will be selected instead of the next one. It seems the arrow keys always start at the top for every dialog opened.

Change History (3)

comment:1 Changed 8 years ago by abeham

  • Milestone changed from HeuristicLab 3.3.6 to HeuristicLab 3.3.x Backlog

comment:2 Changed 6 years ago by gkronber

  • Priority changed from lowest to low

comment:3 Changed 4 years ago by mkommend

  • Milestone HeuristicLab 3.3.x Backlog deleted
  • Resolution set to obsolete
  • Status changed from new to closed

This ticket is obsolete due to the changes in #2025.

Note: See TracTickets for help on using tickets.