Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1582 closed defect (duplicate)

Views are not resized correctly on netbooks

Reported by: gkronber Owned by: ascheibe
Priority: medium Milestone:
Component: General Version: 3.3.5
Keywords: Cc: achiya.e@gmail.com

Description


Attachments (5)

IMG_14092011_111418.png (74.5 KB) - added by ascheibe 11 years ago.
View resizing problem on Vitaly's PC
IMG_14092011_115200.png (109.5 KB) - added by ascheibe 11 years ago.
Some information about Vitalys PC
IMG_14092011_120041.png (98.6 KB) - added by ascheibe 11 years ago.
Trying to pull the tab out of the window also doesn't fix the problem
IMG_14092011_120222.png (65.4 KB) - added by ascheibe 11 years ago.
Some more strange behaviour on Vitalys PC
screenshot_settings.png (69.2 KB) - added by ascheibe 11 years ago.
This shows how to change the "Language for non-Unicode programs" settings

Download all attachments as: .zip

Change History (20)

comment:1 Changed 11 years ago by gkronber

  • Cc Achiya.e@gmail.com added

comment:2 Changed 11 years ago by gkronber

This problem occurs when the display settings are configured to a font size of 125%

comment:3 Changed 11 years ago by swagner

  • Status changed from new to accepted

comment:4 Changed 11 years ago by swagner

  • Component changed from Optimizer to General
  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.6

comment:5 Changed 11 years ago by swagner

Added FAQ and described how to change the Windows text size settings here?.

comment:6 Changed 11 years ago by swagner

  • Status changed from accepted to readytorelease

comment:7 Changed 11 years ago by swagner

  • Cc Achiya.e@gmail.com removed

comment:8 Changed 11 years ago by gkronber

  • Cc achiya.e@gmail.com added
  • Owner changed from swagner to gkronber
  • Status changed from readytorelease to assigned

comment:9 Changed 11 years ago by gkronber

This also occurs on machines with a font size of 100%.

comment:10 Changed 11 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.6 to HeuristicLab 3.3.x Backlog
  • Owner changed from gkronber to ascheibe

Changed 11 years ago by ascheibe

View resizing problem on Vitaly's PC

Changed 11 years ago by ascheibe

Some information about Vitalys PC

Changed 11 years ago by ascheibe

Trying to pull the tab out of the window also doesn't fix the problem

Changed 11 years ago by ascheibe

Some more strange behaviour on Vitalys PC

comment:11 Changed 11 years ago by ascheibe

Vitaly says that he tried it on a Windows XP and a Windows 7 machine with HeuristicLab 3.3.3, 3.3.5 and 3.3.5 nightly builds. The language on the systems is english and font size is normal.

comment:12 Changed 11 years ago by ascheibe

I found another cause for this resizing problem. If the Windows settings for "Language for non-Unicode programs" is set to e.g. Latvia, the views are not resized correctly. There is no problem if this is set to English or German. Vitaly has confirmed that changing this setting fixed the problem, though the disadvantage is that programs, that use non-unicode functions, don't display text correctly.

Changed 11 years ago by ascheibe

This shows how to change the "Language for non-Unicode programs" settings

comment:13 Changed 11 years ago by ascheibe

There will be a workaround for the resizing issue. The problem seems to be in the DockingMainForm and the UI library it uses. We will therefore offer an alternative MultipleDocument Interface (see ticket #1652).

comment:14 Changed 11 years ago by ascheibe

  • Resolution set to duplicate
  • Status changed from assigned to closed

I'm closing this ticket because we have now a ticket (#1652) with a solution for the problem.

comment:15 Changed 10 years ago by mkommend

  • Milestone HeuristicLab 3.3.x Backlog deleted
Note: See TracTickets for help on using tickets.