Opened 10 years ago

Closed 10 years ago

#1498 closed defect (done)

`BestQuality` Value in Symbolic Regression is greater than 1 with Pearson R² Evaluator

Reported by: cneumuel Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.4
Component: ZZZ OBSOLETE: Problems.DataAnalysis.Regression Version: 3.3.4
Keywords: Cc: mkommend

Description (last modified by gkronber)

I have experienced BestQuality values which exceeded 1 in SymbolicRegressionProblems. This should not be possible.

Steps to reproduce:

  • New Genetic Algorighm
  • New Symbolic Regression Problem (single objective)
  • Run (it does not always happen, but if repeated a few times it occurs)

Attatched is a hl-file which shows in the Runs that the maximum quality was greater than 1 in a few runs.

Attachments (1)

SymbolicRegressionGA.hl (1.2 MB) - added by cneumuel 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by cneumuel

comment:1 Changed 10 years ago by cneumuel

  • Description modified (diff)

comment:2 Changed 10 years ago by gkronber

  • Status changed from new to accepted

comment:3 Changed 10 years ago by gkronber

  • Milestone changed from HeuristicLab 3.3.x Backlog to HeuristicLab 3.3.4

comment:4 Changed 10 years ago by gkronber

This happens because of numerical instability when either the estimated values or the target values are very large or very small.

comment:5 Changed 10 years ago by gkronber

r6095: added check for very small and very large values in mean/variance calculator to fix numeric instability problems.

comment:6 Changed 10 years ago by gkronber

  • Description modified (diff)
  • Owner changed from gkronber to cneumuel
  • Status changed from accepted to reviewing

comment:7 Changed 10 years ago by gkronber

  • Description modified (diff)

comment:8 Changed 10 years ago by mkommend

  • Owner changed from cneumuel to mkommend
  • Status changed from reviewing to assigned

comment:9 Changed 10 years ago by mkommend

  • Status changed from assigned to accepted

comment:10 Changed 10 years ago by mkommend

  • Status changed from accepted to reviewing

comment:11 Changed 10 years ago by mkommend

r6104: Updated SymbolicRegression unit test due to the changes in the R² evaluator.

comment:12 Changed 10 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to readytorelease

Reviewed changes in r6095.

comment:13 Changed 10 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.3 to 3.3.4
Note: See TracTickets for help on using tickets.