Opened 9 years ago

Closed 8 years ago

#1413 closed defect (done)

Remove bugs in BubbleChartView

Reported by: mkommend Owned by: abeham
Priority: medium Milestone: HeuristicLab 3.3.4
Component: Optimization.Views Version: 3.3.4
Keywords: Cc:

Description (last modified by mkommend)

Corrected bugs:

  • Some points jump to the borders if the jitter factor is changed.
  • Changing of the point size redraws the points without respecting their current color.
  • Provide a new default setting for the point size (it should be a little bit smaller).

Some additional bugs occured:

  • Automatic coloring resets the jitter values.
  • Selected axis flip back to previous axis value if a run was opened before.

Attachments (2)

bubblechart_updating.png (23.4 KB) - added by abeham 8 years ago.
Shows what happens when new runs are added to the bubble chart, the axis scale correctly, but the labels are not updated.
bubblechart_doubleclick.png (31.4 KB) - added by abeham 8 years ago.
Shows what can happen when one zooms in (y-axis only in this case) and then double clicks to zoom to standard again. The y-axis label interval is not updated.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 9 years ago by gkronber

  • Summary changed from Remove bugs in BubbeChartView to Remove bugs in BubbleChartView

comment:2 Changed 8 years ago by mkommend

  • Status changed from new to accepted

comment:3 Changed 8 years ago by mkommend

r5824: Corrected jitter in RunCollectionBubbleChartView and adapted default bubble size.

comment:4 Changed 8 years ago by mkommend

  • Changing of the point size redraws the points without respecting their current color

This issue can't be reproduced in the current implementation.

comment:5 Changed 8 years ago by mkommend

  • Owner changed from mkommend to swagner
  • Status changed from accepted to reviewing

comment:6 Changed 8 years ago by swagner

  • Owner changed from swagner to mkommend
  • Status changed from reviewing to readytorelease

Great, thanks.

comment:7 Changed 8 years ago by mkommend

  • Description modified (diff)
  • Status changed from readytorelease to assigned

comment:8 Changed 8 years ago by mkommend

  • Description modified (diff)

comment:9 Changed 8 years ago by mkommend

  • Owner changed from mkommend to swagner
  • Status changed from assigned to reviewing

r5976: Corrected bugs regarding automatic coloring and axis value changes in RunCollectionBubbleChart. Additionally removed feature to drag runs because it was useless.

comment:10 Changed 8 years ago by swagner

  • Owner changed from swagner to mkommend
  • Status changed from reviewing to assigned

I reviewed the changes and the bug regarding automatic coloring is resolved. Thanks. However, regarding the axis value changes I still observed a small bug:

  1. Select some value for the x and y axis.
  2. Double-click on a bubble to open the view of the corresponding run.
  3. Go back to the bubble chart and change the value of an axis.
  4. Click somewhere on an empty spot in the chart area.
  5. Observe that the previous and not the newly selected value is shown on the axis.

Furthermore, I do not think that the feature of dragging runs out of the bubble chart is useless. For example, it can be quite useful to be able to drag interesting runs directly from the bubble chart into a new run collection. Therefore, I recommend that this feature is not removed.

comment:11 Changed 8 years ago by mkommend

  • Owner changed from mkommend to swagner
  • Status changed from assigned to reviewing

r6026: Removed bug regarding the axis value change.

comment:12 Changed 8 years ago by abeham

  • Owner changed from swagner to abeham

I will give the bubble chart another test with a larger experiment that I have

comment:13 Changed 8 years ago by abeham

  • Owner changed from abeham to mkommend
  • Status changed from reviewing to assigned

The bug is still not completely resolved, but the way to reproduce it is different:

  1. Open an algorithm experiment with some runs, choose e.g. "BestQuality" on the y axis and "Index" on the x axis
  2. Now go to the y axis combo box, open it and press "r" or any other key (to jump to e.g. RelativeDifference... entry). Close the combo box by clicking on it (not on the value in the list)
  3. You'll see that the axis description has changed, the newly selected value is listed as visible as the text of the combo box, but the points and axis values are still in the old place. It only works when you really select the item in the drop down list (which is already appearing as selected in the combo box).

Since the axis description already changes an event must be received somewhere. Probably there needs to be an additional trigger in recalculating the points on the chart area.

Btw, you've got the same -1 x-axis start problem that I had to cope with in the DataTableView. E.g. list some runs by index on the x-axis and you'll see that the label starts at -1. You probably need to force set the minimum to the minimum of the points.

Changed 8 years ago by abeham

Shows what happens when new runs are added to the bubble chart, the axis scale correctly, but the labels are not updated.

Changed 8 years ago by abeham

Shows what can happen when one zooms in (y-axis only in this case) and then double clicks to zoom to standard again. The y-axis label interval is not updated.

comment:14 Changed 8 years ago by mkommend

  • Status changed from assigned to accepted

r6094: Correct bugs in bubble chart (index starts with -1, double click on points that lie on axis, changing the axis value by a key stroke).

comment:15 Changed 8 years ago by mkommend

r6096: Fixed remaining bugs in the bubble chart. The wrong y-axis labels still appear but are corrected immediately.

comment:16 Changed 8 years ago by mkommend

  • Owner changed from mkommend to abeham
  • Status changed from accepted to reviewing

comment:17 Changed 8 years ago by abeham

  • Status changed from reviewing to readytorelease

Thx for fixing these bugs. I'll change my fix for the -1 start value to use the IsMarginVisible property as well.

comment:18 Changed 8 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.3 to 3.3.4
Note: See TracTickets for help on using tickets.