Free cookie consent management tool by TermsFeed Policy Generator

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1366 closed defect (worksforme)

ObjectDisposedException in View for ProgrammableOperator

Reported by: gkronber Owned by: gkronber
Priority: medium Milestone: HeuristicLab 3.3.3
Component: Operators.Programmable Version: 3.3.3
Keywords: Cc:

Description

In the source code editor, hovering over an error with the mouse shows the error message in the tooltip. Hovering over the error for a while caused an ObjectDisposedException.

ObjectDisposedException: Cannot access a disposed object.
Object name: 'XmlDoc'.
   at ICSharpCode.SharpDevelop.Dom.XmlDoc.GetDocumentation(String key)
   at ICSharpCode.SharpDevelop.Dom.DefaultProjectContent.GetXmlDocumentation(String memberTag)
   at ICSharpCode.SharpDevelop.Dom.AbstractEntity.get_Documentation()
   at HeuristicLab.CodeEditor.ToolTipProvider.GetMemberText(IAmbience ambience, IEntity member)
   at HeuristicLab.CodeEditor.ToolTipProvider.GetText(ResolveResult result)
   at HeuristicLab.CodeEditor.ToolTipProvider.OnToolTipRequest(Object sender, ToolTipRequestEventArgs e)
   at ICSharpCode.TextEditor.ToolTipRequestEventHandler.Invoke(Object sender, ToolTipRequestEventArgs e)
   at ICSharpCode.TextEditor.TextArea.OnToolTipRequest(ToolTipRequestEventArgs e)
   at ICSharpCode.TextEditor.TextArea.RequestToolTip(Point mousePos)
   at ICSharpCode.TextEditor.TextArea.OnMouseMove(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseMove(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.Run(Form mainForm)
   at HeuristicLab.Optimizer.HeuristicLabOptimizerApplication.Run()
   at HeuristicLab.PluginInfrastructure.DefaultApplicationManager.Run(ApplicationDescription appInfo) in C:\reps\HL trunk\HeuristicLab.PluginInfrastructure\3.3\DefaultApplicationManager.cs:line 123
   at HeuristicLab.PluginInfrastructure.DefaultApplicationManager.Run(ApplicationDescription appInfo)
   at HeuristicLab.PluginInfrastructure.Manager.PluginManager.Run(ApplicationDescription appInfo) in C:\reps\HL trunk\HeuristicLab.PluginInfrastructure\3.3\Manager\PluginManager.cs:line 131
   at HeuristicLab.PluginInfrastructure.Starter.StarterForm.<>c__DisplayClass8.<StartApplication>b__6() in C:\reps\HL trunk\HeuristicLab.PluginInfrastructure\3.3\Starter\StarterForm.cs:line 145}}}

Change History (5)

comment:1 Changed 13 years ago by swagner

  • Milestone changed from HeuristicLab x.x.x to HeuristicLab 3.3.3
  • Owner changed from swagner to epitzer
  • Status changed from new to assigned

comment:2 Changed 13 years ago by epitzer

  • Owner changed from epitzer to gkronber

@gkronber: Can you provide an example file? I cannot reproduce this behavior.

comment:3 Changed 13 years ago by gkronber

Could not reproduce this error in revision r5414.

comment:4 Changed 13 years ago by gkronber

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:5 Changed 13 years ago by swagner

  • Version changed from 3.3.2 to 3.3.3
Note: See TracTickets for help on using tickets.