Opened 10 years ago

Closed 8 years ago

#1290 closed feature request (rejected)

Implement symbols for reading and writing memory cells (stores) for GP

Reported by: gkronber Owned by: gkronber
Priority: low Milestone: HeuristicLab 3.3.x Backlog
Component: Problems.DataAnalysis Version: branch
Keywords: Cc:

Description


Change History (7)

comment:1 Changed 10 years ago by gkronber

  • Status changed from new to accepted

comment:2 Changed 10 years ago by gkronber

Added branch directory with r4896.

comment:3 Changed 10 years ago by gkronber

r4897:

  • Added interpreter with support for memory operations to branch.

r4898:

  • Added symbol and tree-node classes for ReadMem and SetMem operations.

comment:4 Changed 10 years ago by gkronber

Operations with side-effects like SetMem and ReadMem are problematic because the order of execution is relevant for the output. Thus, our simplification procedures and probably also pruning procedures do not produce semantically equivalent symbolic expressions as these procedures do not consider such dependencies.

comment:5 Changed 10 years ago by gkronber

  • Status changed from accepted to assigned

We should adapt simplification routines to handle SetMem and ReadMem operations correctly and merge these changesets back into the trunk.

comment:6 Changed 8 years ago by gkronber

  • Status changed from assigned to accepted

We should not try to integrate all kinds of possible functions into the standard interpreter for symbolic regression. Instead we should think about ways to easily add such kinds of symbols in case they are useful for a given GP problem (see #2026).

The branch for developments for this ticket and his ticket should be closed.

Last edited 8 years ago by gkronber (previous) (diff)

comment:7 Changed 8 years ago by gkronber

  • Resolution set to rejected
  • Status changed from accepted to closed

r9484 deleted obsolete exploration branch.

Note: See TracTickets for help on using tickets.