Opened 10 years ago

Closed 10 years ago

#1237 closed enhancement (done)

Create subclass of chart to implement advanced functionality

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.2
Component: Visualization.ChartControlsExtensions Version: 3.3.2
Keywords: Cc:

Description (last modified by epitzer)

  • save of image
  • copy image to clipboard
  • panning
  • zoom out on double click
  • customized scroll bars

Change History (35)

comment:1 Changed 10 years ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 10 years ago by mkommend

Added first version of EnhancedChart with r4614.

comment:3 Changed 10 years ago by mkommend

  • Owner changed from mkommend to epitzer
  • Status changed from accepted to assigned

comment:4 Changed 10 years ago by epitzer

  • Status changed from assigned to accepted

comment:5 Changed 10 years ago by mkommend

Corrected Visualization.ChartControlsExtensions project file with r4616.

comment:6 Changed 10 years ago by epitzer

  • Description modified (diff)
  • Owner changed from epitzer to mkommend
  • Status changed from accepted to assigned

Add zoom reset by double click, panning and a method to obtain a prettier default chart area (r4621)

comment:7 Changed 10 years ago by mkommend

  • Status changed from assigned to accepted

Minor changes in EnhancedChart with r4628.

comment:8 Changed 10 years ago by mkommend

Corrected ZoomReset in EnhancedChart with r4630.

comment:9 Changed 10 years ago by mkommend

Minor changes to EnhancedChart and the adapation of the RunCollectionBubbleChart with r4635.

comment:10 Changed 10 years ago by mkommend

  • Owner changed from mkommend to epitzer
  • Status changed from accepted to reviewing

Please review the made changes and test the implemented features. Afterwards assign the ticket to swagner for review.

comment:11 Changed 10 years ago by epitzer

  • Status changed from reviewing to assigned

comment:12 Changed 10 years ago by epitzer

  • Status changed from assigned to accepted

comment:13 Changed 10 years ago by epitzer

  • Owner changed from epitzer to swagner
  • Status changed from accepted to reviewing

More improvements to EnhancedChart (r4636)

  • Fixed panning (now snaps to selected cursor interval)
  • Changed chart type in DataTableView to EnhancedChart
  • Added static method CustomizeChartArea()
  • Changed CustomizeChartAreas() to CustomizeAllChartAreas()
  • Disabled cursor cross hair
  • Smaller title font

comment:14 Changed 10 years ago by swagner

  • Status changed from reviewing to assigned

comment:15 Changed 10 years ago by swagner

  • Status changed from assigned to accepted

comment:16 Changed 10 years ago by swagner

Worked on visual appearance of charts and added some other minor corrections in r4637.

comment:17 Changed 10 years ago by swagner

  • Owner changed from swagner to epitzer
  • Status changed from accepted to assigned

comment:18 Changed 10 years ago by epitzer

  • Status changed from assigned to accepted

comment:19 Changed 10 years ago by epitzer

  • Owner changed from epitzer to swagner
  • Status changed from accepted to reviewing

Fixed panning (r4638)

comment:20 Changed 10 years ago by swagner

  • Owner changed from swagner to mkommend
  • Status changed from reviewing to readytorelease

comment:21 Changed 10 years ago by epitzer

  • Owner changed from mkommend to epitzer
  • Status changed from readytorelease to assigned

comment:22 Changed 10 years ago by epitzer

  • Status changed from assigned to accepted

comment:23 Changed 10 years ago by epitzer

  • Owner changed from epitzer to mkommend
  • Status changed from accepted to reviewing

Fixed rounding to correct interval (r4646)

comment:24 Changed 10 years ago by mkommend

  • Status changed from reviewing to readytorelease

comment:25 Changed 10 years ago by mkommend

  • Status changed from readytorelease to assigned

The SaveFileDialog should be reused and not created for every export operations. Additionally it must be checked if the restore directory flag works as intended.

comment:26 Changed 10 years ago by mkommend

  • Status changed from assigned to accepted

comment:27 Changed 10 years ago by mkommend

  • Owner changed from mkommend to epitzer
  • Status changed from accepted to reviewing

Reused SaveFileDialog and renamed menu item to "Export Chart" with r4654.

comment:28 Changed 10 years ago by epitzer

  • Owner changed from epitzer to mkommend
  • Status changed from reviewing to readytorelease

comment:29 Changed 10 years ago by abeham

  • Version changed from 3.3.2 to 3.3.1

Set version to 3.3.1. Please change to the actual version when the plugin has been released and the plugin version is incremented.

comment:30 Changed 10 years ago by swagner

  • Owner changed from mkommend to swagner
  • Status changed from readytorelease to assigned

comment:31 Changed 10 years ago by swagner

  • Status changed from assigned to accepted

comment:32 Changed 10 years ago by swagner

Removed context menu in DataTableView in r4749 as it has been replaced by a context menu in the base class EnhancedChart.

comment:33 Changed 10 years ago by swagner

  • Owner changed from swagner to mkommend
  • Status changed from accepted to reviewing

comment:34 Changed 10 years ago by mkommend

  • Status changed from reviewing to readytorelease

comment:35 Changed 10 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.1 to 3.3.2
Note: See TracTickets for help on using tickets.