Opened 11 years ago

Closed 10 years ago

#1225 closed defect (done)

The status of executables views is not updated correctly

Reported by: mkommend Owned by: mkommend
Priority: medium Milestone: HeuristicLab 3.3.2
Component: Optimization.Views Version: 3.3.2
Keywords: Cc:

Description

Following steps are necessary to reproduce this behavior:

  • Create new experiment
  • Add two algorithms or batchruns
  • Start 2nd executable => the views of all optimizers are locked
  • Start 1st executable => still all views are locked
  • Stop 2nd executable => all views are unlocked even of 1st(still running) executable

Change History (7)

comment:1 Changed 11 years ago by mkommend

  • Status changed from new to accepted

comment:2 Changed 11 years ago by mkommend

The problem is that these views (AlgorithmView, BatchRunView, ExperimentView) do not adapt their status if the content is changed and therefore always reflect the status of their surrounding view (e.g. ViewHost, CollectionView,...).

comment:3 Changed 11 years ago by mkommend

Corrected the status of executable views in the OnContentChanged method with r4540.

comment:4 Changed 11 years ago by mkommend

  • Owner changed from mkommend to gkronber
  • Status changed from accepted to reviewing

Please test and verify the changes. If everything works as intended assign the ticket to swagner for reviewing.

comment:5 Changed 11 years ago by gkronber

  • Owner changed from gkronber to swagner

Tested and seems to work fine now. Nice that only views of running optimizers in the experiment are locked. Parameters in one optimizer can be adjusted without stopping the whole experiment.

comment:6 Changed 11 years ago by swagner

  • Owner changed from swagner to mkommend
  • Status changed from reviewing to readytorelease

comment:7 Changed 10 years ago by swagner

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.1 to 3.3.2
Note: See TracTickets for help on using tickets.