Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1204 closed enhancement (rejected)

All CollectionView should react on MouseDown instead of SelectedIndexChanged

Reported by: mkommend Owned by: mkommend
Priority: high Milestone:
Component: Core.Views Version: 3.3.1
Keywords: Cc:

Description

This is necessary to allow the ViewHost the reuse of Views. SelectedIndexChanged sets the selected item to null and so the active view is disposed by the ViewHost.

Change History (7)

comment:1 Changed 10 years ago by mkommend

  • Owner changed from swagner to mkommend
  • Status changed from new to assigned

comment:2 Changed 10 years ago by mkommend

  • Status changed from assigned to accepted

comment:3 Changed 10 years ago by mkommend

  • Resolution set to rejected
  • Status changed from accepted to closed

This ticket cannot be implemented as intended. It is not possible to skip the multiple SelectedIndexChanged events or to treat selection changes in other events. Therefore ticket #1211 was created.

comment:4 Changed 10 years ago by swagner

  • Version changed from 3.3.0 to 3.3.1

comment:5 Changed 10 years ago by swagner

  • Milestone changed from Iteration 4 to Current

Milestone Iteration 4 deleted

comment:11 Changed 10 years ago by swagner

  • Milestone changed from Current to HeuristicLab 3.3.0

Milestone Current deleted

comment:12 Changed 10 years ago by swagner

  • Milestone HeuristicLab 3.3.1 deleted
Note: See TracTickets for help on using tickets.