Opened 11 years ago

Closed 10 years ago

#1173 closed enhancement (done)

Extend csv importer for data files to support more data formats

Reported by: gkronber Owned by: gkronber
Priority: low Milestone: HeuristicLab 3.3.3
Component: Problems.DataAnalysis Version: 3.3.3
Keywords: Cc:

Description

A basic heuristic to automatically detect the separator character would be nice.

Attachments (1)

importer-error.jpg (64.6 KB) - added by gkronber 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by gkronber

  • Version changed from 3.3.0 to 3.3.2

comment:2 Changed 10 years ago by gkronber

  • Milestone changed from HeuristicLab x.x.x to HeuristicLab 3.3.3

comment:3 Changed 10 years ago by gkronber

  • Status changed from new to accepted

comment:4 Changed 10 years ago by gkronber

Implemented heuristic to determine the file format when importing data tables and test cases with r5013.

comment:5 Changed 10 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from accepted to reviewing

comment:6 Changed 10 years ago by gkronber

  • Owner changed from mkommend to gkronber
  • Status changed from reviewing to assigned

comment:7 Changed 10 years ago by gkronber

Recieved a bug report related to this ticket.

Last edited 10 years ago by gkronber (previous) (diff)

Changed 10 years ago by gkronber

comment:8 Changed 10 years ago by gkronber

Could not reproduce the bug. However, changed the culture-info string from "de" to "de-DE" with r5096. Maybe this solves the problem?

comment:9 Changed 10 years ago by gkronber

  • Owner changed from gkronber to mkommend
  • Status changed from assigned to reviewing

comment:10 Changed 10 years ago by mkommend

Removed unused methods in TableFileParser with r5369.

comment:11 Changed 10 years ago by mkommend

  • Owner changed from mkommend to gkronber

Reviewed changeset r5013.

comment:12 Changed 10 years ago by gkronber

  • Status changed from reviewing to readytorelease

comment:13 Changed 10 years ago by mkommend

  • Resolution set to done
  • Status changed from readytorelease to closed
  • Version changed from 3.3.2 to 3.3.3
Note: See TracTickets for help on using tickets.